RESTORE DATABASE is terminating abnormally


#1

Hi,

Copied the database for the original machine and then tried to restore it onto a new device but an error comes us


#2

What does it say?

The system cannot find the file specified.

C:\Users\Sam Tang\SambaPOS4.mdf

Please post a screenshot of the DB Backup Settings …


#3

it also cannot find …sambapos4_log/ldf


#4

Try disabling Allow Overwriting... setting.


#5

tried disabling ‘allow overwriting…’ but it says

'the backup set holds a backup of a database other than the existing sambapos4 database. ’


#6


#7

Even though this shouldn’t really affect it but can you try putting that backup file in a new folder in C: drive?

Then try to restore database from there. And also tick allow allow migrate after restore and see if that works.


#8

Hi Shivan, I’ve just tried that but the same error is still coming up


#9

Just tried it on SambaPOS5 and restore using the same file is fine


#10

What kind of backup is it. Can you show the backup file?


#11

It is a .BAK file which is in a SQ file


#12

I know this is old, but this is the ONLY post I could find regarding this issue and was wondering what the solution is.


#13

Your problem is probably not the same. Start by showing us the error report. Explain what your issue is. Show some screenshots of the error.


#14

There isn’t a log that is generated for me for this issue, so essentially I am just creating a backup system in case the old system stops working one day. The photo of the error is the same as this one, but rather it has my system name and that is about it. I did the same steps and got the same results as OP here.


#15

Any suggestions? Can’t seem to figure out the issue still.


#16

Hi, I have been trying to restore to database to new computer from old one but I am getting exactly same problem…( it’s so frustrating not getting anywhere… please help me…:pray:

Thank you.


#17

Can you copy paste the entire error log for it?


#18

Exactly same error. I have tried everything people said on the forum but no luck so far :unamused:


#19


#20

Your connection string doesn’t look right to me… It has server name but no instance name in the data string. Either the backsplash is in wrong pla e or the colon in the middle is messing up.
Surely there isn’t a colon in PC/server name?
Change the colon between PC and SQL parts for backslash and take one off the end…