Samba POS 4 when installed worked fine now not Loading

I think it should generate a different error message now. Maybe it can give an idea.

Is anyone else able to network samba v4

My guess is that SQL Server Browser is not running and therefore not allowing remote connections. Check the instructions ->
for setting up SQL.

I have Now got the two pc linked together but now it say

Reinstall latest SambaPOS V4 on all terminals to update database to latest version.

I have now Update the software to the latest version on all pc. Now the connection string has appeared again the link worked before. the only thing i have change is the software version.

If displayed connection string is the working connection string you might have a problem with sql server. Check if it is running and automatically starts running on windows start.

have checked it is all running sql server config

Today, I’ve upgraded V4 to 1.8 and I now I get this same error message like you “check database version”.on client which are on version V3 or V4 1.7.
I tried to downgrad on 1.7 but I got this message on all PC.
So the only way is to upgrade all client on V4 1.8 or restore database (and not install 1.8 if someone would like to use V3 anymore on other PC)
Because the problem is that V4 needs “windows framework 4.5” and that Windows XP don’t support framework 4.5.
So people who has XP and wants to upgrade to V4, must install other version like VISTA, 7 or 8.
Before V3 and V4 worked together now, with 1.8 it’s impossible.
If V4 1.8 is installed on server, all clients PC need V4 1.8 to work and not get this wrong message about database.

I had this problem as you now. I have window 7 and upgraded all versions of sambapos to V4 1.8 Now the connection string don’t work. you got any idea why this has happened.

Sorry i think I can’t help you about your problem because I’ve installled V4 1.8 on other PC with window 7 and that works with my connection string. The only step I had to do it was to allow firewall about this connection. (automatic windows message appeared on screen about firewall to sambapos programm and I clicked “allow”).
So I opened v4.1.8 on my client, I entered connection string then save then reboot sambapos and that works.

Maybe that could help you, first screen on server and second screen on client. Both V4 1.8 (first on 8 and second on 7)

On PC with seven, it was the first install (not an updgrad)
But this client PC was already set on the same network (to other application)

i solve the problem and now i can run sambaPOS4 on client-PC, here what i did

My Terminal was working fine but suddenly not connecting with the string , But I tried ip address and its working message server not connected what could be th eissue pls thanks.

Ensure the Message Server is running on the Server.

If you had to change your Connection String to use an IP instead of a name, then something changed on your network - this could also affect your messaging service on the Client.

@Jesse ,@Emre I Need Help on this issue, I was running A sql 2014 Server and Pos Client smoothly since fewdays .Since 20days its not connecting to server, trying everyday I thought updates might a problem uninstalled updates .still there is a problem my both server and client running windows 7 pro Server 64bit, client 32bit, and I connected my laptop which run windows8.1 is working without any firewall off and also dell venue windows tablet also working and connecting which is 8.1. But I don’t need laptop or tablet client is Important and its touch pos. I used same string for all devices

Yesterday I wiped out client pc and re installed OS , and installed samba and the problem is same only way I can connect with ip address and message server cannot connect same time . iam happy to continue with ip string but need advice is this a proper way to connect ? what about msg server?
All devices are fine except this client pc string is ok what could be the issue? and suggetions would help a lot thanks.

That sounds like a firewall issue. However I think I understand but just to clarify can you show some screenshots of what you mean by this:

What port did set MSG server on?
Does your server have Network Discovery turned on? It may be the client side firewall from the client and not the server causing it. Your not running a DNS service?

I am asking a lot of questions because you have not given enough information I need to fish for it. My first instinct tells me its a firewall issue.

1 Like

@kendash Thanks for quick suggestion my msg server is 8383 , Before clean install OS also ableto connect with ip and after OS Install also can only connect with IP , and in ip tcp I use 1433 port , All firewalls are Off anyway I will post screen shots in short time thanks.

I am not sure there is a proper and non proper way to connect other than if it doesn’t work then that would be not proper. But if you want to fix the reason why using the server name doesnt work then we need to figure out more about your network setup.

Internal network IP or internet IP?

Is network discovery turned on for the Server?

@kendash Its internal ( And Network discovery is on can see workgroup pcs , I hope its not server firewall as I can connect my laptop and tablet thanks