SambaPOS Database Configuration


#41

@atman Try this it may help you.


#42

Thankssssssssssssssss :slight_smile:


#43

Hello I am having a problem With the conecction string for SAMBAPOS3

I am using SambaPOS 3 because I have Windows XP Systems.
I was moving from Stand Alone to SQL Server Multiuser, and I installed the Stand Alone Database in SQL server.and when I created the connection string I have a mistake in creating the connection string. I typed the incorrect Server name and saved and exit SambaPOS 3
SO since then I am unable to login again, I uninstalled and Reinstalled Samba 3 several times but Still having the same error :smile:

Can’t Connect to database with current settings. You can check and modify the connection string shown below.

This is in my server installation.

I dont know how to change the connection string since I do not have access to SambaPOS3.

This is in my Server POS so my whole restaurant operation is halted. Some body please help.


#44

Look for the Settings file as mentioned in this thread. It contains the connection string and is a simple text file, so you can modify it to contain the proper information. It should look something like this:

<ConnectionString>Data Source=localhost\sqlexpress; User Id=sa; Password=yourpassword;</ConnectionString>

#45

Thank you!!
I did rename the file C:\ProgramData\Ozgu Tech\SambaPOS3\SambaSettings.txt
and I was able to connect again.
Thank you again.


#46

Thought I had it all worked. Installed SQL Server Seemed all good. Finished Setting up my menu etc in Samaba. When I went to do a backup I got a error message. After trying to correct the issue I got myself into a bigger mess. I now have this message and I have NO idea what I should do.


#47

Your connection string is wrong. Your string should look like:

Data Source=NATASCAFE\SAMBAPOS;

Not:

Data Source=NATASCAFE/SAMBAPOS;

However can you explain exactly what you did to correct the error. It would be beneficial if you told us what the error was as well.


#48

I’ll try my best…Where do I change that ?
The original error message was


#49

BTW that error is permissions you should always store backups outside your users folder. Or you could mess with permissions but it is not recommended.

Now to answer your question

Enter it from the dialog that is popping up that you showed in the screenshot. Then press ok it will make you restart SambaPOS.


#50

Also those backups are CE not SQL backups…

This means you probably never were connected to your SQL server and it looks like when you tried to fix it you did set it to connect to a server you just set your string wrong.


#51

OK…I didn’t realize I could make the change you pointed out in the message box.
I did that and Samba now opens.
Original issue still exists


#52

You should change where it is storing your backups and make sure it is not in the users folder… then run a backup.

Best practice is to get an external HD that you can save your backups to. Several good USB ones exist that are very inexpensive.


#53

This is where I start to feel really dumb.
I Have no idea where to fix it


#54

PS: Here is an updated Tutorial showing how to setup and use the most recent version of SQL Express.

http://forum.sambapos.com/t/sql-express-2014-installation-sambapos4-database-setup/3363


#55

if the file is supposed to be a zip file…I may be good


#56

Yes it automatically zips it


#57

OK…I’m goint to try to restore the file on a different computer which has the same version of samba and sql server as well


#58

Sorry to get off task here but have to ask @kendash ive seen youve posted a few screenshots where the standard grey background is now black, i assume an update for places with low lighting likes bars that was once requested a while ago?

Is this part of some new features being released soon??? :slight_smile:


#59

You may like this one better: (Finally someone asked lol)


#60

I think I need to eat…nothing makes sense to me regarding the setup of samba with the backup file I now have on a second machine…