SambaPOS Database Configuration


#21

Thanks, I am sure that I have installed sql server correctly.
Network services are enabled
mixed mode is activated
any other way we can check connection from client computer to server computer database?
how can i even set back sambapos to normal mode( local database in document folder)
I tried uninstalling it and install again but i cant open same string problem coming up.
if i access the server as remote user does ticket prints on another printer?
I mean can we use another printer via remote access?


#22

Try logging into SQL Server Management Studio using SQL Server Authentication

If you get an error then the Mixed Mode authentication is not working.

When you say ‘set back to normal mode’ are you using Compact SQL (CE) (SambaPOS4.sdf database file) on the main computer ?

The connection string is stored in the SambaSettings.txt file. To change your connection string, run SambaPOS, and when you get the error message that it cannot connect, change the connection string in the dialogue box and this will update the connection string - just run SambaPOS again.

You can control printing via Rule Mappings or in Manage->Settings->Terminals. Rule Mappings provides better control.


#23

Hi All,
Sorted the problem, just updating the solution if somebody have problem with connecting terminal to server pc.
one is adding port number 1433 to tcp/ip in sql server configuration manager.

other is adding ip address of server-pc to the connection string

this will solve the problem, I am uploading this because I took one day to solve this
Thanks to All.
Sid.


#24

OK, it definitely isn’t the port number as SQL Server uses dynamic ports by default - which is why WIndows Firewall will always block SQL Server. This also makes me think that Named Pipes isn’t enabled in SQL Configuration.
The other reason could be that your computers can’t resolve NETBIOS Names (ie DNS), hence why you need to use IP addresses.


#25

yes @JohnS might be, I have gone through all steps again and again the did all changes, then i installed sql server and checked is it connecting to network database or not, it was keep on failing then i tried with IP address then it going through. Once it connected the I made changes in connection string. All done!
Thanks…!!!


#26

Please help!!!..Thanks!!!





#27

can you please show your full connection string.


#28

@siwa, from the SQL server management screen i can see the database name is TONY2013\SAMBAPOS3

so the connection string should start with:

Data Source=TONY2013\SAMBAPOS3; User id=

and NOT

Data source=localhost\SAMBAPOS3

if you can also show full connection string as per JohnS suggestion.


#29

@JohnS
@morshed1
Data Source=TONY2013\SAMBAPOS3; User Id=SAMBAPOS3; Password=1234;
Thanks!


#30

That’s not right. User id should be User Id=sa

What password did you set when you created the SQL Instance SAMBAPOS3 ?

Did you read http://sambapos.org/wiki/doku.php/en/installing_sql_express_2012_for_sambapos_v3


#31

@JohnS I had istalled SambaPOS 4.1.36 , and did follow http://sambapos.org/wiki/doku.php/en/installing_sql_express_2012_for_sambapos_v3

with all the images above, can you please show me what to fill in below…

Thanks!


#32

@siwa you need to enter Data Source, User id and Password correctly and what you need to enter here depends on your installation. From your past screen shots we can understand Data Source should be TONY2013\SAMBAPOS3. User id is generally sa if you didn’t intentionally changed it. Finally password should be what you’ve set while installing SQL Server. Since you can login to management studio you should already know what it should be. You can test your user name and password out of SambaPOS as shown under this post. Sambapos4 string problem

For testing you can try leaving user id and password blank if SQL Server installed on same computer and your local account is an administrator. But for accessing SQL Server from other computers you need to enter user id and password while configuring other terminals.


#33

@emre @morshed1 @JohnS Thanks guy!!!


#34

Greatings all, long time :smile:
I finally moved from windows XP to windows 7, have latest framework, migrated my 33mb sdf! file to a lovely SQL server 2012, have sambapos 4.1.53 :smile:

Question: i want to see if everything is OK with my data and for that i need to do some testing in sambapos, and the thing is that work period is off for now and i dont want to start (at CE mode i used to backup the sdf file, then starting work period to run tests, then i restore the sdf file to its real time version)
how can i do that?

*sorry if its discussed a lot - i didnt have much time lately to catch up…


#35

easiest way is to download the Database Backup module from the market and use it to backup/restore… or you can use the Microsoft SQL Management Studio to run backups.

Here is what the Database Backup module looks like when installed:


#36

Great thanks! i’ll check it


#37

The module is the easiest way, but you can also use Management Studio, and it is simple as well…


#38

Thanks @QMcKay for now i did use Management Studio for backup, but im planning to do both.

BTW, in “Back Up Database” window (in Management Studio) its important also to go through “Options” tab - my main thing is “Overwrite” instead of “Append” - i just heard bad stories with this append thing…


#39

I created a new user in Windows and reinstalled. This was the only way I could get back to the normal mode.


#40

Hi all,

I have the same problem. I guess I have wrongly entered the info during my previous login to SambaPOS. I am not able to start SambaPOS now with the error.

Is there any way to relaunch SambaPOS so that I can change the details?

Thanks
Atman