SambaPOS Database Configuration


#81

ok…that’s done… What next


#82

Shut down sambapos then restart and then go to Samba Market and login… Should be able to install the tool.


#83

yes…did that tool shows up now


#84

A few months of use and you will be a pro!

BTW I am not very good at making Cappuccino lol. We have thought about starting a Coffee Bar in our restaurant but machine cost etc really has me scratching my head.


#85

If you’re ever in Peterborough Ontario Canada I’ll show you all you need to know.

How do I get Samba to use the backup zipped file?


#86

Go to the tool and go to settings and point it to the dir you saved the file. then logout and log back in and go to that tool and your backups will appear. Just select one and choose restore. If you want each computer to save to a different location then set them differently from within settings and choose the option Restore from Zip. And point it to your file.


#87

seems I’m not learning quick enough
I now have this on the second machine


#88

If you installed SQL Express the same way on that machine it should be:

Data Source=localhost\SambaPOS 

or

Data Source=STEVE-PC\SambaPOS

Above is assuming SambaPOS is what you set as your instance name.

Now if you set the instance name to something else then you would need to figure out what the instance name is by opening Microsoft SQL Server Management Studio and looking at the Instance Name there.

If you left it default try SQLEXPRESS as instance name.

You only need to add

Database=

if you have more than 1 database you are using under that instance otherwise leave Database= out of the string.


#89

getting closer I think


#90

Yes you need to move the database backup file to a dir other than C:\users… due to permissions.


#91

ok…moved it and now


#92

Try checking this:


#93

hmmm…checked over right on restore and got this


#94

Go to Settings > Local Settings > Database and enter this as your connection string:

Data Source=localhost\SambaPOS; Database=SambaPOS5

Save it and shutdown SambaPOS and then restart it… then go to Market activate the tool again and then from the settings page of that tool check the box to overwrite file name then try to restore it.

EDIT: actually you need to delete the other database first. Do you have MIcrosoft SQL Server Management Studio installed?

Open MSSMS Login and look at the following.


#95

ooopppss…I don’t do well to read the entire post…

I did what you said in the first half and it worked!
Except I have the activate module window popping up


#96

Just go to Samba Market and login and activate the module.


#97

In fact for testing purposes you can make multiple databases under the single instance. You notice I have 3 DairyCreme, DairyCremeTest, and SambaPOS4.

You can swap to them by simply changing Database= inside your connection string.


#98

I know…go to samba market and clear keys!


#99

No no need to do that again just login and choose activate. I am talking about from within SambaPOS not the website.


#100

That’s not working unfortunately…continues to pop up