Sambapos's misbehaviour on one of my Tax transaction?

Hey guys, I think I found a bug where Sambapos ‘missed’ my GST tax transaction.
So i’ve tried to find out why my Tax total in the report doesn’t match G.S.T total in my Navagation screen’s Account button (See image 1 & 2)

Image 1, with correct Tax total of $36.62 (GST tax 10% of subtotal )

Image 2, with incorrect G.S.T(Tax) total of $36.17 (difference of $0.45 to Tax total, but the only tax I have is GST :open_mouth: )

Sales: [=F(-1*(TN(’{ACCOUNT TOTAL:Sales}’)+TN(’{ACCOUNT TOTAL: G.S.T}’)),‘0.00’)]
Raw Sales: [=F(-1*(TN(’{ACCOUNT TOTAL:Sales}’)+TN(‘0’)),‘0.00’)]
GST: [=F(-1*(TN(’{ACCOUNT TOTAL: G.S.T}’)+TN(‘0’)),‘0.00’)]

image 3: anyway, I tried searching for the culprit and I think it’s this ticket.Ticket number #266 and it also shows tax total of $0.45. however. . .

image 4: there are no G.S.T transaction account for that ticket,

image 5: here’s the transaction record for ticket #266, notice how there’s no G.S.T transaction, nor any tax transaction (yet the subtotal for tax is still correct in the report somehow)

image 6: Here’s what my other ticket looks like, with G.S.T tax transaction where it should appear :slight_smile:

Unfortunately, this is where I’m stuck at. So is this a bug (G.S.T Tax transaction not logged), or was my setup incorrect somewhere :O?

I think I found a way to duplicate the issue now.

###If I do the following:

  1. Tap quantity (e.g. ‘2’)
  2. Tap product (e.g. ‘small rice’)
  3. submit ticket order
  4. result: No issue

###but If I do the following:

  1. Tap product (e.g. ‘small rice’)
  2. Tap the same product again (e.g. ‘small rice’)
  3. submit ticket order
  4. result: G.S.T. Tax transaction not recorded.

I notice you have a rounding calculation. Can you show that config? Also show your tax config.

Pm me a backup of your database I can take a look.


Thanks :slight_smile:

Very Strange I am going to include Emre in this PM.

Funny thing is it doesn’t have to be the rice to replicate the issue, it happens with any of my products (provided I manually selects them twice).

So i’m very curious if this issue only happens to my DB or ?

Its definitely a bug and its not just your DB. I just confirmed it with my own. If you add order twice by pressing button twice it will not create the tax transaction. Emre is looking into it.

1 Like

Is it just if they are added in sequence one after another?

From my test, it only happens when they are added in sequence. So if you add product A, then product B, then Product A , the tax transaction will work like normal I think

Emre responded and it’s a problem with merge lines option in program settings.

A fix is being tested.


Umm, wow.

In-sequence is not necessary either. More than 1 of the same Product within a Tax Group will wipe out all taxes in that group, so long as it is all done in the same Order and not split across Orders at different times within the Ticket.

Product A (tax1)
Product B (tax1)
Product A (tax1)
Product C (tax2)
Product D (tax1)
Product C (tax2)

That ^ will effectively wipe out all taxes from both tax1 and tax2 groups, because I selected the same product twice out of each tax group. And it does not matter if you select another one-off out of the same tax group, it’s taxes will be wiped out as well.


Sorry @QMcKay you probably didnt see our conversation I will invite you now. This has been fixed in a private release I am sure he will release it for all soon.

1 Like

Holy… Am I gonna get penalty from Revenue Agency :hushed:

You collected correct amount. Also your work period report will reflect correct amount. Accounts would not be correct until you run a fix Emre did.

If you did not have merge lines enabled then your fine.

A lot ppl will like it if it make sales disappear :wink: Gonna be great hidden feature ever LOL

1 Like