SQL server issue

I am trying to hook up my dell Windows operating tablet to the pos system but it won’t connect to the server. The computer says it’s connected but this is what the tablet does:

This is what is going on for the host computercomp

more problems here…aa2a1

Why using such an old decrepit version of sql server?

Looks like your network is not setup correctly or you don’t have some sql settings or pipes open up.

1 Like

You will need to either open SQL Config Manager or Computer Management on Main computer running the SQL server.
One there find the Protocols for SQL server and ensure TCP/IP & Named Pipes are both enabled. Like below.

After that you will need to setup a port for SQL server so that clients wanting to connect to the server can access it using the IP address and Port specified.

You can do this by right clicking TCP/IP and going to Properties>IP Addresses…

Scroll all the way down to the bottom. and under the part that says “IP All” Remove whatever is in TCP Dynamic Ports and under TCP Port. Type a relevant port. The one I use is 49170.

Once saved, restart your SQL server service.

Then you may be required to allow the port through the windows firewall first.

After firewall setting is done, on your tablet test to first ensure you can ping the server machine local IP address such as or whatever the local IP address is on the main machine.
Another method for this is open Command Prompt and type ipconfig. You can find your local IP address under IP address Protocol Version 4

Then on your tablet your database string should look something like this…

That should do it for you.

You can also disable firewall to allow this to work too however I personally don’t recommend it as if you are allowing internet access on the systems, you are making your PC vulnerable to attacks.

Hope this helps.

1 Like

I am using such an old tool because the computer I have is 32 bit and won’t install a newer version, and when I downloaded SQL it didn’t have the option to download the management tool. But now that I know I can use the config manager I won’t be using it anymore!

I did all of this using configuration manager on my host machine and it still connects fine. However my tablet still won’t connect (note I changed the database name the way you did involving the IP address instead). It gives me the same error as before. Do I have to do the same thing through configuration manager on my windows tablet?

On your tablet… are you able to ping your host?
Did you create a firewall rule in windows to allow others to be able to access remotely?

Have you tried turning your firewall off to see if you can connect using your tablet ?

If it works with firewall off then it means you haven’t created a firewall rule or you set firewall rule incorrectly.

I will post a video that helps demonstrate how to make SQL access remotely.

You can use that as a reference as I did and it worked perfectly for me.

Update: I am using TOAD to try to connect, but it is not working out for me, so I am not sure my server is set up right. Here are pictures from the host computer

By default, SQL Server uses the following 2 Ports, for which you need Firewall Rules (Inbound, allow, enabled) on the Server:

  • TCP 1433
  • UDP 1434

I added the two rules and still no luck.

And this is the error when trying to connect

Please do us a favor and take screenshots and paste them here pictures of a screen with a phone are hard to see and i certainly dont like tilting my head to read an error.

Press print screen then just simply paste it here.

1 Like

Sorry. The only reason I was doing that is because the host machine is very old and slow, so it takes quite a while to compose and publish a post. Here is the error on the windows run tablet being used to connect to the host.

What kind of ip address is that? Isn’t ipv4 and doesn’t look like ipv6 either.
Did you do the trunks bit of the SQL tutorial? I’ve missed that step before.

1 Like

I just went into CMD and typed ipconfig and used the address under IPv4 address. I’ve watched many tutorials on setting it up, but maybe I missed something. Is there a resource you can direct me to that shows me how to do that?

Its defiantly not IPV4, take of the 92.164 at the beginning… sounds more like a normal ipv4 address of a LAN

1 Like

I think you’re right, how do I get it to be changed?

It would be imposible to have an IPV4 address with 6 sections, think your just connecting to wrong location. Does it work with

1 Like

Now this is what I get…

This is where I got the IP address from