Strange upgrade V4 - V5 database issue

Dear all,

Today i tried to upgrade from V4 to V5,
I followed the instruction from here : How to Upgrade v4 Database to a New V5 Database

Everything went well, but when i tried to restore the V4 database, strange issues showed up (like the picture below).

I’m not sure what caused this, but i tried to reinstall couple times with multiple database names and still no luck.
I also realized that the database state become (restoring…) forever in SQL management.

Any ideas how to solve this?

Thanks before,

Probably not your problem but do you have all the tickboxes ticked in the settings tab of backups? Specifically the allow overwrite database files?

@JTRTech Yes i did ticked all the backup settings tab, including allow overwrite database files.

You may find a solution here.

Or maybe you can just delete database and start over.


I tried couple method listed in that page before, but still no luck.
When i tried to recover the database, it says :

"Msg 4333, Level 16, State 1, Line 1
The database cannot be recovered because the log was not restored.
Msg 3013, Level 16, State 1, Line 1
RESTORE DATABASE is terminating abnormally."

It’s weird since the backup contains both data and log file.
I did tried to delete and make couple new database with different names. It’s all end the same way with the same error.

I also realized that i couldn’t restore the Backup Settings as well, it says “Sequence contains no elements”

Not sure what you mean by this. How is restoring Backup Settings different form Restoring the backup?

How did you backup?

It appears something is wrong with your backup or your installation of SQL server.


Oh, i mean i also having trouble to restore the setings as well, not only the database.
I also tried to restore on different computer, with different SQL server. But still got the same error :frowning:

Which settings are you referring too…How did you make the backup?

I had this same issue, i just deleted the database from management studio and created a new one and restored backup to it then it worked


I’m using regular backup module from 4.1.82
Database Backups -> Backup Database
Database Tools -> Tools -> Export to file

Wow, that’s strange… Since i also tried to delete the database from management studio multiple times and restored backup with multiple database names and still no luck :frowning:

Strange it must be something to do with how your SQL server was setup when you ran the backup. You can PM me a copy of your backup and I can test it if you like.

Thanks a lot for your help Kendash, i’ll PM you my backup copy now.

Not sure what to tell you but it restored just fine on mine.

Are you sure you followed EVERY step in my tutorial? You did restore from zip file? You ensure all options in Database Backup module are checked?

How are you making the new databases?


Wow, the database works? That’s weird.
I tried it three times with different database names just now, and still not working

i’m curious, so i tried to restore the database in 4.1.82 (version where i made the backup)
and apparently, i got the same error. So i think it’s related to my SQL server settings (i’m using SQL server 2014).
i’m going to try re-install my SQL server and downgrade it to 2012. I’ll keep update the results here.

Anw, Here’s my settings & error screenshot :


Update :
I re-installed SQL Server Express 2014 : Not working, still the exact same error. :frowning:

I’m confused why is it working for you and not for me :frowning:
Can you share your SQL version and did you use any specific settings?

I pretty much using the standard settings described here :

I use SQL express 2014. Follow the tutorial I made for installing it the tutorial you linked is old. There is a link to the updated 2014 tutorial in the welcome to v5 post.


I’ve re-install SQL express 2014 with the tutorial you’ve provided.
Tried to restore the backup again, and still the exact same error happened.

Try the restore from zip option and select the zip file.

If you didn’t tried before unzip and restore backup file via sql management studio.

btw did you tried solutions suggested on stackoverflow website?

1 Like

@Jesse @emre

I FINALLY can get this backup to work!
I still couldn’t restore the backup through SAMBAPOS

I use this command to restore the backup file. Just like emre said, unzip and restore via sql management studio

FROM DISK = ‘MyDatabase.bak’

Everything works fine now :smile:

PS : Out of curiousity. I made a backup again in SambaPOS 5 and tried to restore it again.
It’s still not working. But again, i can restore it through SQL management studio using above command.

Thanks @emre , @Jesse , & @JTRTech for helping me solving this problem.


Source Link :