TEM EGE Scale v5

I have a Tem EGE Scale and it is predefined at SambaPOS. Thats really nice. But there is no affect at POS Screen when i put any weight to the scale. I set the right COM Port and also tested the scale with the TEM EGE’s Technical personnel. I saw its working well. Mean there is the communication but samba cant get it.

I also read this one [New 4.1.4] Scale Integration and watched the video.

But there is kinda no hope for it. Can u please help me about it ?

Well how disappointing. It is really hard to understand why hardware manufacturers can’t preserve a single communication protocol between their releases. Having official support for hardware is always a regret…

@mehmet can we obtain these models for my next visit?

When use the predefined TEM EGE option scale does not affect anything at samba.

Then i tried it with the custom settings instead of predefined TEM EGE option.

And also with the CAS ER predefined option.

Result is like this:

Hi @Yasin_Cabuk,
Use Custom Scale and edit Match Pattern to ([0-9]+[.\\,]+[0-9]+) for Tem EGE scale.
But Tem Ege scale is not good idea, it’s very bad scale.

I recommend Cas ER Junior Scale.

1 Like

Thank u for the info about TEM.

But i tried the Match Pattern, and the result is same again.

This is the result with the Scale mode which sends data continuously.

The other way:
When i make it “send data manually” , SambaPOS is showing the weight for a moment and it is dissappearing forever.

This is an All in One system. Scale+Printer+TouchScreen PC Combined. And this TEM EGE is our first try.
I hope i wont have to hang with this dud thing.

Ok. @Yasin_Cabuk This blink problem’s source is TEM Ege Scale, because this scale send blank line.
Please change your Scale DLL to attachment for SambaPOS V5.1.60.

Samba.Addon.ScaleDevices.zip (5.0 KB)

-I just copied this dll to sambaPOS installation dir after installing the 1.60 cuz i was using the 1.59 .

-There was no change. And i removed the Scale Module from the Samba Market. And restarted the samba.
-Tried the scale after this, but there was nothing cuz of there was no module installed.

Then i installed the module and restarted samba again but im here where i just started :slight_smile:

Do i need to copy the dll to system32 or anything else to do ?

DLL copy location is SambaPOS installation after than C:\Users[UserName]\Belgeler\SambaPOS5\Addons

I did it too, and tried several time with the serial and manuel mode with the scale but the result is not good.
Also tried wih the predefined TEM EGE Scale and Custom Scale.
There is no communication after the dll.
Original dll provides a flashing communication at least …

Hi Guys, I need help URGENT please in setting scale to samba pos, I have gone through all the related topics but nothing works for me please help!

  1. I have TEM EGE-M SCALE just bought with RS232 connection it has
  2. I used Serial port to USB as My computer does not have old com port
  3. I ran putty and nothing is showing up (I can see in devices that com6 is connected) I tried all the ports also but nothing works
  4. Putty is blank and setting in Sambapos is also doing nothing.
  5. in Sambpos I tried custom scale and also TEM scale options, BUT nothing works
    Please guide how to resolve this?

here are some images for ref:

If putty is getting nothing samba wont magically see something putty doesnt. You need to change config.
Issue may be the usb adapter/drivers, never had much luck with usb serial adaperters for anything myself.