Ticket printing begin issue

Hi to everyone, I am new to samba and I think it is great… I have a problem within printing tickets.
At the begin of the first line of every new ticket appears the B character…

This does not happen with the first ticket after the reboot of the pc but only with the nexts

Thanks in advance and sorry for my english

Have you changed the template?
Is printer set to ticket printer?
What printer you using?

thanks for the quick response…

I have chenged the template but it’s the same with the default one.
The printer is set to ticket printer and the model is ZJiang 58mm.

I think the issue is linked to the line character count. If i leave the default setting is ok but it prints over the paper limit.

I guess thats the little chinese plastic ones you get for £25-30 on ebay.
I have used them before with no issue.
58mm character count is about 32, what you got set?

Be sure its set to ESC/POS emulation mode from the printers drivers.

1 Like

Yes is chinese plastic one, and I have set to32
I can’t find ESC/POS in the printer proprieties or drivers…

Does it add the B on every line of a ticket or the first line of each ticket?

Only on the first line of each ticket


Hmmm, ok
Have seen single character on first line on few printers before but not all the time only on first print.
The epson printers at hotel print a special character on first line of first print of the day after boot.
You say its doing it on every ticket?
Is was serial like a tm88 might have said a dip switch setting for parity or hand shake or something like that but this printer is USB right?
Just to check can you send screen shot of your template firstly? or if you too new to forum and dont have upload option copy and paste the template but select the </> button on the post box so that it doesnt strip the code.

Can you show us screenshots of the drivers settings?

it prints B on every ticket and it’ s USB. This is the template code:

-- General layout
<L00>Ticket No:{TICKET NO}
[<J10>Total Gift:|{ORDER STATE TOTAL:Gift}]
<J10>Totale:      {TICKET TOTAL}
<C10>G R A Z I E




-- Default format for orders

-- Format for gifted orders

-- Nothing will print for void lines

-- Format for order tags

-- Table entity format
<L00>Table: {ENTITY NAME}

-- Customer entity format
<J00>Customer: {ENTITY NAME} | {ENTITY DATA:Phone}

@kendash i can’ t post images… too new.

thank you for all

OK, just wanted to check no stray letter (no offence to your abilities) :smile:
Presume you installed the drivers provided with the printer? Was it new?

You can now I changed your account permissions.

PS: this is something we see on the forums fairly often and most of the time ESC/POS emulation needs to be turned on.

this is the driver version (i hope):

and this is a sample ticket:


Yes the printer is new and I have installed the driver provided by the verdor.

I also try HTML printing mode but no difference

The setting kendash refers to might be in device settings… Can you screenshot that tab?

is this?

  1. Switch off printer.
  2. Press feed button.
  3. While holding feed button switch on printer.

That should print a page about printer settings. You’ll find selected emulation mode there. Check if it is star or esc/pos emulation. Selected language might also be the reason of that.

Looking at your settings it is set to bleep before every print, dont know about yours but dont think my similar printer has a buzzer!
Try turning that off.
B - maybe thats the driver trying to tell it to bleep!!

1 Like

Good thought. !B is beep command. That might explain that mysterious B letter issue.