Issues with Chinese Printer

As per some previous post like that below I am getting a B on first line of every print.

Have not had a printer with this issue before so been unable to test.
As you’ll know Im pretty good at this sort of thing but this has me stumped…

Things I have done;

Tried both given drivers and generic/text drivers…
Checked all print driver settings - turning of bleep and cash drawer in driver…

Changing to Test printer in samba stops it but don’t want plain text…

Any suggestions on other things to try?

Have gone back to looking at these printers as have half a dozen I could do with using.
Further testing reveils that it doesnt print the B if changed to windows printer…
They print as expected in ticket (exc/pos) mode in samba except the B on first line…
Any ideas?

They B cheap. Lol really I have no clue.


They do indeed be cheap…

Just odd and annoying that after 40-50 printers all of a sudden having this same issue with all 6 which are from 3 different sellers with difference model/version numbers (although similar printers).
Just supports the suggestion that everything comes from the same bloody factory and just slap different stickers on em.

Hehe, back when I last did a big stock up I cleared ebay uk of any reasonable condition good priced epson t88s, looks like the users of ebay has replenished the supply, used but for good prices cant go wrong :slight_smile:

Does notepad prints fine? Did you tried text printer?

1 Like

Windows test print and notepad print fine.
Other options in samba print fine: HTML, text, raw etc just not ticket printer.
Tested on v5 and exact same…
Tried all driver settings and multiple drivers both from inc discs and others found online.
Is similar problem to the other topic describing same issue…
It prints on the beginning of the first line of every print in ticket printer mode…
The rest of the print is fine just adds a b on first line…
As I said have at least 3 different models or at least versions of same machine, physically the same but through different ‘factories’/brands…
The test prints are exactly the same and drivers give exact same options and descriptions so expect internals and firware are similar.
I think it’s something samba specific, googling doesn’t come up with anything similar other than this and the other topic on samba… Given the amount of these printers sellers are selling would expect other people to be having same issue of it was completely down to the printer.
What’s different in ticket printer mode? Does samba send and commands automatically?

ESC-B is Beep command. Maybe it can’t process that command and prints it. Does printer drivers sends a beep or adds something like that?

That’s what I thought at first but when set to ticket printer in samba driver advanced options seem to be bypassed.
For example in notepad or Windows printer in samba the kick command in driver works, if in ticket printer in samba it doesn’t and XCT code needed.
Sam goes for all the driver options, extra feed etc.

While reviewing I noticed I’m sending 66,0 value for cut command m,n parameter.

66 is also equals to ascii value for B Letter. Doesn’t it recognize that parameter and prints B instead?

Does it cuts properly? Does it prints B letter just after the cut? Can you check the paper that remains inside printer after it cuts? Does it have B letter?


It doesnt have a cutter, its a 58mm tear off printer.
Its printing on the first line of the print.

Or… is it really printing the “B” after the ticket prints, but you cannot see it because the paper is still in the printer? :wink:

Im sure I checked and feed the paper to see if that was the case… will double check in a bit.

And so probably, in answer to Emre’s question: it in fact does not understand the CUT (B) command.

Hmmm, I was thinking I had to add a cut command on system with cutter but actually I havn’t…
Will double check if its printing on first line or below the tear mark.

Its defiantly at the beginning of the print…
Feed paper before and after print and its on the first line at beginning of print.
Doesn’t do it on the first print after turning on bizarrely which is what made me question if like you said it was printing below the tear line… but it is defiantly at beginning.

Maybe you try reset ESC @ (I guess) before printing. It (b) maybe just stuck there.


Hmmm think you have a solution there :slight_smile:
@sukasem that seems to work.
But needs to be there in the template ll the time, it doesnt clear the issue, removing it makes it start again… not sure what that means…

That mean it is because of cut command for sure but I can’t process and stick in printer memory.

I think won’t hurt to have ESC @ on the top of printer template.