Unidentified network - wired through switch


#1

god damn again the multi terminal setup is giving me a headache again.

Just will not connect to the network, rebooted, reinstalled, reset ip… im out of options.

It seems to be a common thing in Windows 10, even ‘troubleshooting’ pops up no errors :confused:


#2

I’ve just reconnected them through wifi again for now. But this really is bugging me :confused:


#3

You mean undefined is what windows says where it should be home, work or public?
I had this and what I ended up having to do was edd it a system option to allow manual change of undefined as default only allows you to change when network is changed/your prompted or between the 3 options if one is set (or not set to there from undefined)
Took 2-3 google searches before found a good guide to doing it.


#4

@GreatShakesBar have you set static local ip addresses on all terminals?


#5

I did do then I changed back… tried both


#6

I tried all options. I changed the network to shared…

Ive told him to wire them all up individually now. They can all connect direct to the switch, bugger it :slight_smile:


#7

Setting up static ip addresses should solve that.


#8

did try it, no success. Might be easier for me to try when they are closed but i just needed to get them online.

Ill go in again later and try again


#9

If the switch is connected to a modem/router then ensure to find firstly what is the default gateway address. it could be either 192.168.1.1 or 10.0.0138 or something along those lines.

next ensure all wired terminals are connected to the switch via ethernet. Then configure the terminal local area connection adapter to static by doing something like below

NOTE: IP address can range be any range between 192.158.1.2 all the way up to 192.168.1.254

So you can essential set the terminals like
server: 192.168.1.5
client 1:192.168.1.6
tablet 1:192.168.1.7
tablet 2: 192.168.7.8
Printer 1:192.168.1.10
Printer 2:192.168.1.11

Alternatively if the Default gateway for the modem/router is 10.0.0.138 then you could do something like

Server: 10.0.0.5
Client1:10.0.0.6
Tablet 1:10.0.0.7
Tablet 2:10.0.0.8
Printer 1:10.0.0.10
Printer 2:10.0.0.11

I usually set “Preferred DNS” same IP address as default gateway as that is where it will be able to connect to the internet if the modem internet is connected to that gateway.

For your tablets you need to set the WiFi adapter settings to static. For Wired you need to set your Ethernet adapter settings.

The settings all depend on the router/modem IP settings.

You should have no problem connecting the wired to a switch, but for wireless it should be connected to a wifi router/modem.

To ensure they are connected, they need to be able to ping each other. you can use windows command to do a ping test to each device static ip address and see if you get a reply. if you do, then you know they can communicate.

Suggestion: Test each device PING on the server machine to ensure it can talk to each device successfully.

Once ping is successful, and if you have your firewall turned off, you should be able to PING the SQL server ip address and port number.
if it pings successfully then all your devices should be able to talk to the SQL server and you should be able to run samba without issues.


#10

isnt DNS normally 8.8.8.8 8.8.4.4 ?

Maybe thats where i was going wrong?


#11

Those dns addresses are googles. Those should be fine but id suggest first try the default gateway ip address as the dns and see if it can at least get online using isp dns. Modem default gateway address sends a dns request through your isp, then your isp looks up the address your looking for via its dns and sends the request back to your modem which then sends it to your browser. Thats how websites are loaded on your browser. So of it works via your isp then it should work with googles dns also.

The important thing is all your devices been able to communicate with each other. This just requires your default gateway, your subnet mask and your ip address to be correct m your devicea should all have the same default gateway address and the same subnet. And dns should match if the system i getting configured to go online


#12

DNS is domain name resolution, and if using static ips and setting conection string to IP it wouldnt even touch any form of DNS.
The unidentified would be your issue as sure unidentified it treated as public/full lockdown on firewall.


#13

The whole thing 100% refuses to identify. I put in the ip and dns and it goes to ‘detecting problems’.

It’s proper frustrating


#14

So the switch isn’t connected to the Internet, one of the tills is wirelessly.

I put it back to auto set and looked at the ip configuration and it shows this…


#15

That IP address is an autogenerated one created when no DHCP server can be found. Is there a PC or router handing out ip addresses from a DHCP server. If not you will need fixed IP addresses as mentioned above. All the IP addresses need to be in the same range set by the subnet mask.


#16

That looks like a self assisted IP.
It’s not in identified that ot doesn’t recognise network it isn’t receiving an IP…
Confirm your network setup and structure in simple text and or a sketch.
If this is a wired one, check the wireing/pinorder - do you have a cat5 cable tester?


#17


#18

Ok,
Can you elaborate what the wifi on the 3rd one is for?
What IPS did you have setup before?


#19

before switch they were all wifi

third one on wifi is for license activation and the fact that one till isnt wired in and connects to the server wirelessly (at the moment)


#20

Where is the server in this arrangment? Wired to same switch?