White gaps in image

Hi guys,

I understand that this may not be a SambaPOS problem but then again it might.

I am using the latest version of SambaPOS V4 running WinXP and have also tried this on V2.99 running Win7. Both have the same issue

My Issue: When I print out images through SambaPOS on my Epson TM-T20 (thermal printer) I get many “white gaps” in the image. This does not occur with the rest of the docket (text). There are also no “white gaps” when I am printing out images (even the same image) directly through windows.
Also, when I switch to print the same thing in SambaPOS from my other thermal printer (Senor GTP-250) there are no “white gaps”… !?

Any ideas? And no using my Senor printer for the images is not a solution.

1 Like

It happens to me to with a BEMATECH MP4200 and a BEMATECH MP2500
I tought it was an image problem…


I have tried to find a solution with my T20.
The only way to successfully remove the white lines is to store the logo in the printer.

I call the logo with


The numbers 32,32 are the numbers assigned to the logo in the printer.

Hey John,

Haha thats exectly how I solved the problem last night ! :slight_smile: Btw. could you please help me out on converting my V2 Printer Templates to V4? I am sooooo stuck. I posted it on the forum

OK!!! that is great news, now… how do i put the png in the printer??? jajajajajajaajajjajajajajajaja sorry. really disoriented here…



Use the TM-T20 utility that was installed when you installed the printer.
There is a logo section in it. I can’t remember if it uses png, but you can always use MSPaint to save as BMP if needed.

yeah but the guy has a BEMATECH MP4200 and a BEMATECH MP2500 so he would have to check if his printers accommodates a similar feature as to the TM-T20

Correct. I lost count of who has what :confused:
Most receipt printers can store logos, and there should be software from the manufacturer to assist in this.

This issue might be something that @emre may be able to solve through code. But it’s possible it’s a Bug in VS.

Assuming we didn’t have such problem with V3 I’ve reviewed V4 code and rolled back some unneeded changes. Unfortunately my printer perfectly prints logo and barcode bitmaps so I couldn’t test if it solves that issue or not. I’ll be happy if you can test it with next release [4.1.18] if white gaps still appears or not.

I odnt know if this is updated or not, but they still appear… using bematech mp-4200 thermal printer



PD on a bematech mp-2500 also thermal printer white gaps do not appear…

Yes some printers does it but I’ve still couldn’t be able to test it with a printer that has this issue.

That resolves if you upload logos to printers and print them. If you search forums @JohnS posted detailed information about it.

1 Like