Caller id popup

Can someone tell me why I have this popup when I set caller id???

Do you have Samba.Addon.CalleridDevices.dll file under [MyDocuments]\SambaPOS4\Addons folder?

OK. I found it. It will work fine on next update.

Is there anything I should do to make it work?
Or there is a problem I have to wait the next release??
Also in the modem settings do I need to set something else besides COM PORT???

I updated to the latest version and connect phone line
I defined modem COM number
But nothing happens when a call comes in
Do I need to configure anything else??

Connect to your modem port with a terminal application such as PuTTY. You can monitor modem data transfer with that tool. Call your modem line. You should see data flow as RING lines. Check if it displays phone number prefixed with a value such as NMBR. Better paste a screenshot here so we can review the problem.

This is how you should configure PUTTY. Click Serial and type COM Port as shown here.

Okay I’ll try it
Where can I download this tool?

Okay … I saw the link

When I call to this line
I have caller ID

Let it ring few times. Some modems displays it after second ring…

I tried to let it ring for a long time

If your modem supports caller id it should display calling number after first or second ring.

If you are sure your modem supports caller-id feature that might be disabled. You can try one of these commands to enable it. You can directly type command on terminal window and press enter.


If one of them works please let us know which one enables it. It should display OK or similar confirmation command if it can successfully enables Caller ID. Call your line again and if it displays number post a screenshot here.

That’s what I get all the commands

No not command prompt. You’ll type these commands on PUTTY window for configuring modem. Also I’ve updated commands. They should start with AT.

I do not know where to paste the command
You can upload a screenshot please???

@pizzaeilat4 on your screenshot there is a green square under NO CARRIER. You’ll type there.

Sorry for bothering you and thank you So much for the great help
The first command AT+VCID=1 works i got ok.
But still it does not work.
Could be my modem not supports Caller ID
Can you recommend a particular model of modem pci or usb thet will work better???

In some cases modem initialization might be tricky.
If you get OK after AT+VCID=1 try this.

  • Type AT+VCID=0
  • Type AT+VCID=1
  • Call your line to test if it displays phone number after RING notification.

If it does not work your modem might not have CID support. I’ve tested some no-name modems with success but I don’t have a universal brand, model in mind. Maybe you can find more info from Google

Although the results are still not working
Do you think it means modem does not support Caller ID???

Yes if the reason is not the line quality your modem does not displays CID information.

I’ve also noticed at+VCID=? displays 2 value as an option. Did you tried that?