CAS PDll Scale integration

Hi All,

I’m trying to connect CAS PD2 scale with SambaPOS no luck so far.

i read all forum and couldn’t find any solution. most of the previous questions were connecting scale to the PC thanks to Tecstore’s tutorial (CAS PDII POS Weighing Scale, TecStore UK & Worldwide) i managed to connect scale to my POS. now i need help with connecting to the Samba…

can anyone help me?

So you’re able to get a reading using Putty?

yes, i managed to get readings from Putty but it’s not continuous feed. Scale only sending data if you press Ctrl+Q from keyboard.

Understood. I don’t use a scale myself. Have you setup a custom scale device in local settings? Maybe look at the debug mode option for troubleshooting.

We are working about this scale. Next version you can use this scale with SambaPOS

1 Like

thanks for the update mate, i’m looking forward to get that update. And also i just ordered cas er jr, i hope i can configure it. i’ll write again if i can’t. thanks everyone again…

I have been able to use the CAS PD 2 scale

Can you share your settings please. i had no luck so far…

Scale ERC Settings: Type-3
Com 1 Settings: 9600/7/even/1/none
Custom Scale

Any idea?


Used a custom scale

remove the , comma and the . decimal since the scale sends in kgs and it has a decimal
and check your pattern at the end remove that *

Your post had two different pattern, i tried both but still no luck…

Most likely it’s not SambaPOS issue, it’s communication issue… i haven’t firuge out how to read COM1 continuously… i talked with CAS support they said only Type 3 sends continuous data. But i can’t read anything on Putty if i choose Type 3. But on type 6 i can get weight data if i hit Ctrl+Q

It’s gonna be mission i guess…

This device waits a char to start sending weight.

Did you remove the comma and the decimal?

My scale sends a continous weight you dont have to press Ctrl Q

Is yours a serial connection? Newer pd2 are usb and not continuous.

yes, it has serial connection…

what is your ECR type?

The newer pd2 scales are usb and do not have a continuous mode we have confirmed this with CAS. They require a command to be sent first. If your scale is one of the newer ones that is why. It’s possible even your serial one is the same.

We will add support for these scales into sambapos soon

Last we spoke to them type 3 will do continuous but only after initialized with a W command first.

This exact scale we are working to build a direct integration for. It won’t be long we will finish it.


thanks for info, what about cas er jr, are they still working with pre set samba configuration?

New CAS ER Plus i ordered yesterday arrived. But still nothing on Putty.

Hey @Wisefix how did you manage to get your Cas Er Plus to connect with Putty? what is your settings and RS232 Cable order?