Datalogic Scanner/scale configuration

Hello Everybody

I buy a datalogic scanner/scale 9500xt recently and m trying to configure it with samba. the problem is when m scanning any barcode scanner giving me a label id with barcode i.e S08xxxxxxxx16. Now my question is does anybody experience the same problem? or does anybody have a experience in it?
I tried to program the scanner by scanning the barcode for label id disable but still same thing.

this isnt anything to do with samba, itll be the configuration of the scanner. You need to read the documents for the scanner as there shoule be some setup barcodes to put the scanner in the correct setting

Don’t understand the question. So the barcode has a prefix and suffix. Pretty common no?

@Faisal maybe you show a photo of the barcode you are scanning, and also what comes up on the system when you scan it?

yeah that is my understanding too but my supplier saying you have to contact your pos software supplier so they have to do some configuration to read barcode with this serail label id.

Hardware suppliers are always very quick to point to POS software suppliers in these situations. But it isn’t wrong too - software takes what the barcode scanner sends. But all barcode scanners have configurable options on what they send.

So if you can supply a photo of the barcode and what is scanned, that is a start, without that I’m sorry I don’t think anyone can help you here…

1 Like

See their reply:

"There should be a setting within your software or your software should automatically remove the S08 when you scan an item. This typically is only visible in notepad because of how it is connected. I would recommend calling your software provider so they can give you the specific programming. They will tell you what the proper communication protocol should be. All pos software is slightly different, we are just a hardware provider. We have confirmed the hardware works and functions as it should. Who is your pos software technical support contact? I have attached some different tags you can try, hopefully they will help.

Thank you,"

Yeah no problem i would post in a while here…
but the actual barcode is 040088214916 of a item and its giving me barcode in notepad is this S08040088214916.

1 Like

So add S08 to your Barcodes in sambapos

1 Like

@Faisal there are lots of different barcode scanner brands and what they’re doing is just scanning the barcode and send the scanned barcode. Some software needs special characters to differ barcodes so scanners may append special characters before or after the barcode data but by default it should send what it reads. Think like you want to use it with Excel to create a product list. Would you contact Microsoft and want from them to remove S08?

In SambaPOS there are ways to remove it by handling “Numberpad Value Entered” event and use some JS code to trim first 3 characters but it unnecessarily makes your task harder.

btw @markjw I accidentally removed your post. I don’t know how did that. I’m sorry.

yes and also in notepad too.

yes i do have idea about it and m trying to sort it out this problem from datalogic supplier.
but one more question @emre i also want to use scale with this so do i have to buy any module for this scale?
datalogic have a dual test and its giving me weight on it. i also tried with CAS ER scale in samba but no luck.

You need to reset the barcode scanner using the configuration sheet that came with it. I had the same problem and fixed it by resetting the scanner.


It is odd for a barcode scanner to add S08 at the start of the barcode as a default configuration unless that is actually part of the barcode. You should have in the instruction manual a lot of barcodes to scan to configure the scanner. Try factory reset one, then see anything to remove the label ID. But your label may show the barcode as 040088214916 in text but the actual barcode may contain S08040088214916. You need to verify that.

Do you have another barcode scanner, maybe a basic cheap one, they usually scan normally by default.

If not, download a free barcode scanner app on your phone and scan the barcode to see what it actually contains. I recommend “Scandit” their app is good and free, scans any type of barcode.



1 Like

i did but m getting the same thing. By th way which model you had? and when i reset the scanner i downloaded a document containing set of barcodes from datalogic 12 digit barcode settings something like that and it was saying after resetting it you must scan these set of barcodes in order to scanner to work.

I didn’t tested it with datalogic scale so I don’t know if it works fine or not. You don’t need to buy a module. You can enable it from Market Screen. It works fine with CAS ER Jr model.

If your scale communicates through serial port you may integrate it with SambaPOS by following steps explained here.

i did all of that already and before i was using a usb scanner and it was working perfectly fine. i read the manual but my understanding is in scanner it have some standards like UPC-A, UPC and EAN, so might be i need to disable one of it to get the scanner remove label and yeah i used it already disable label id barcode but same thing.

i cant use numberpad action because every time i would have to press enter when samba reads barcode but is there any way to separate S08 from barcode by using script? in samba.

So it’s your scanner problem. If it worked with a USB scanner before with the same barcode, there is your problem. Why are you using the Datalogic scanner? Some of these more expensive scanners have strange default configurations.

Actually - search google for “datalogic scanner s08” one result I found:

Just search the page for “s08” you will find it says the barcode contains “s08”. This is your issue, it is not the datalogic scanner it the label printed by your scale. (I did not read that page in full though).

Did you actually try the datalogic scanner with another barcode, like on a product like a bottle of coke?