Email WorkPeriod Report and Gmail settings

Dear All, I tried to send Work Period report with Gmail Settings. It is successful and I can send reports from Gmail to Gmail. Please, check attached PDF file.Remark: you have to enable POP and IMAP setting in Gmial Setting.
Email EOD WorkPeriod and gmail setting.pdf (587.2 KB)

3 Likes

But this is not an issue is it? Unless I misunderstood you I have changed your topic to Tutorial since it seems this is what you are doing. Issues category is for breaking SambaPOS application issues like crashing for no reason and its not related to configuration mistake.

1 Like

Thanks for your correction.

I do it too, but i have problem if user end of period and then close sambapos app, so email not send.

So try putting it in a different event?

Hello I was trying to find the file location of reports but I couldnt find them can anyone please guide me with this.
Ive tried C:\Users\YAMITECH\Documents\SambaPOS5\ but no report file found
have a great day

Reports are not stored. They are generated.

thank you so first I have to make an action to save file

File Name should be… ?

You choose…
It ideally is not in documents folder as permissions can be a pain.

C drive in new folder called reports?

The folder needs to be created but action will create file.

1 Like

ok I was following this tutorial and the file name part was kind of confusing

good afternoon here in Perú
can someone tell me where am I wrong? any help will be appreciated
have a great day!



Looks like samba cannot access H drive, you’ll need to save the file somewhere else

1 Like

I tried all my drives and couldnt make it work :confused:

Wonder if that file name path from another tutorial is the key ¿?

You need file name on that he
H:\reports\reportemail.csv

The screen shot is using variable in filename which shouldn’t be needed if not needed to be kept as can just be static and overwritten.

You also may get issue of file cannot be generated quick enough for email sending action to have file available. This can be resolved by splitting the rule into two with either execute automation command with delay or background option set

1 Like

thank you it helps a lot = )

Maybe these are older screenshots but last time I saw this mentioned I’m sure there was a command name option on export report which would remove need for execute command action as the export action would trigger the command on export completion.

I did what you Sir suggest me and found this:


this is what I understood from that post… but still cant send the report by email =/



this is the enviar email action btw