Entity Search Columns Not Saving

Using 5.2.22 with SQL Express in Win10.

Trying to setup a new environment to demo and I’m having problems with getting the search columns to save.

I’ve searched and read that you should be able to use the field chooser and modify the columns, immediately log out and close Samba, and then launch Samba again to have the settings saved.

I’ve done that and even tried modifying the files to remove columns and it didn’t make a difference. I have even tried clearing out the layout files under documents to go back to defaults but after deleting the files, I do not see new files being created.

I’ve also tried reinstalling Samba.

Any other directions anyone could possibly send me in?
Thanks

Did you exit design mode before clicking Save button?
It works, but I also often lost my edits when skipping one of those steps. It is easy to forget.

@VehbiEmiroglu, The layout editing section is definitely in need of debugging and improvements. Editing of the Entity Search layout sometimes results in corruption of the layout file, after which we must either restore the file to an older version (always keep backups of Layouts! ) or delete the layout file and start editing all over again, which itself is rather problematic.

Because of the crude behavior in layout design mode I suspect most people abandon Layout mode for general Entity Screen design purposes and opt for Custom mode instead.

If layout design mode was improved and easier to use I think it would be used more because it allows us to rapidly create neatly arranged screens with widgets aligned in boxes. It makes it easier to upgrade screen designs according to changing needs or design evolution as compared to the process required to move groups of widgets around in Custom mode. It’s not obvious but we can even copy and paste widgets from a Custom screen to a Layout based one and keep all the widget settings we created.

Migrating from Custom screen to Layout based one would be easier if it supported multiple widget selection for copy and paste, and that would make Custom ES design easier also.

The Tabbed Control box is also a unique feature of Layout mode which is very useful for Entity custom data editing when there are many fields.

You can separate fields into categories that way to provide a neat and logical layout and better UX.
But the few quirks, limitations and bugs in layout mode make it unsuitable for most situations. Currently you can spend more time trying to reverse engineer the behavior than creating a layout!
It’s in need of a detailed tutorial at least.

Tab header font size needs to be adjustable to accomodate various screen design scaling.

I have exited the design mode before exiting and closing out of the program. I’ve also tried dragging columns off the layout screen as well. No matter what method I’ve utilized, it doesn’t save.

I’ve tried deleting the layout file but it doesn’t make any difference and it doesn’t recreate with our entity fields configured. We’re creating customer entities and are trying to customize the search layout screen and remove columns that are not needed for normal searches.

I’m not in front of it right now but I’m guessing it may have to due with the number of fields for the entity or something similar. If I recall correctly, If we delete the database and start with a default layout and entity fields, it creates the file and saves the changes.

If we restore the database, with multiple entity fields, it fails to work properly. The fields are fundamental customer fields, such as first name, last name, address, city, etc with a few additional fields for notes. I am planning on trying to start from scratch and narrow down when and what seems to cause it to not work properly.

With us preloading entities in, the custom screen was very sluggish to get to. To emphasize, this is based off my memory and may be a bit off. I’ll try to post/edit when I’ve gotten to run through it again.

As an additional note and separate topic, trying to customize the layout when adding in a new customer led to a ridiculously large xml file and sluggish response. As such, we were planning on leaving it to the default layout of one row per field, which leaves quite a bit of vertical scrolling but significantly improved responsiveness.

Thank you for taking the time to add some information.

Please note there are 2 steps needed for saving the layout.
Exit Design mode + Save (as if saving changed data entered).
I assume you did that, but worth clarifying.
There is usually no need to exit the program to use the new layout.

Are you sure you deleted both layout files?
There is one XML file used for saving the matching search items Grid Layout.
The Grid layout file is named “EntitySearch_someEntityScreenName.xml”
The other XML file is used for storing the Entity Editor layout.
The Editor layout file is named “LC_someEntityTypeName.xml”

P.S. the problem reported isn’t related to the Entity type definition in this case but a new bug as confirmed by markjw below. … so you can safely ignore my comments about Entity Type definition below for this problem. Below comment is for a different problem which can cause a conflict with Entity Search layouts:

If you changed Entity Type custom fields after already creating Entities for that type, there can easily be a mismatch between the custom fields schema and the actual entity data.

Do you have lots of customer data already stored? or only developing?
If you already have live data, you can first export the data using Data Export definition in Reports section.

I suggest creating a fresh Entity Type and importing the data using Batch Create Entities.
(If the field names changed, you would probably need to edit a copy of your Exported data to match the new field names, or you could create the Data Export to match the new schema appropriately.)

Please be aware his question is not related to design mode or saving a layout. It is related to saving entity search columns, for example on the default entity search screen.

Yes, this is how it is supposed to work and yes, it did used to. I confirm it also appears not to be possible to save in v5.2.22 no matter what you do. Myself I have reverted to taking layout files from previous systems and copying them to new setups, or editing the XML files manually.

I had been meaning to report this bug myself for some time…

@VehbiEmiroglu can you look into this please, definitely it is not saving now in v5.2.22.

1 Like

It probably relates to some library changes that were made.

1 Like

Possibly, but it happened in 5.2.22 not the beta version.

1 Like

Ok i will control this. Thanks for reporting.

@VehbiEmiroglu, I can confirm his report of sometimes producing a large XML file and thereafter experiencing a very slow rendering of Entity Search Screen or Widget. It can take several seconds to open the search screen under those conditions whereas prior to Design mode changes, the screen opened almost instantly.

That bug has been around for years and the main reason I avoid using Layout mode. One workaround is to always make a backup of the Layout folder prior to doing any Design mode layout changes and restore when the XML file goes crazy.

Layout files exist in custom mode as well. Layout was added later as an easier method to setup screens. People struggled understanding how to size widgets in custom mode.

The C# logic for updating the LC_somescreen.xml files is buggy which leads to huge numbers of empty LayoutGroup elements created in the file and that’s what causes the very slow rendering he reported.

Any chance there’s an update on the column modifications being savable?

Have you tried the latest version?

Yes. Just tried yesterday.

You are right I will add it to the redmine.

EDIT: It is added in the redmine. I can not guarantee when it will be fixed but it should be looked at.

Is there anyway to sign up to be notified when its resolved?

I have a few clients that will move over once this is fixed and they’ve been waiting.

Happy New Year.

I will let you know. An entity column is preventing them from using SambaPOS?

BTW I see you are in Florida. Are you interested in reselling SambaPOS? It sounded like you were? I am CEO of SambaPOS USA Inc. Shoot me a PM if your wanting to inquire about reselling SambaPOS in the USA.

PM Sent with some responses.