How to add a terminal to SambaPOS

Ok

On server machine. Open sql management.
Then remove whatever is in server name. And type the system ip address followed by the sql port number.
E.g. 192.168.1.2,49170
Change authentication to sql server authentication.
User name should be sa
And insert password.
If you successfully connected and can view database in object explorer. Then just try putting those settings into sambapos in client side and see if it connects ok

OK
SQL Server management is connected successfully from client pc but Samba POS could not connect. Just get an message…

I am not sure about the message.
Please give me a solution.

See my SQL Management Studio screen shot…

Does it happen when you try to run SambaPOS from Client? Be sure SambaPOS in installed on the client is same version with the SambaPOS installed on server.

That connection string doesnt look right to me… for thesource
It is usually Data Source=HOSTNAME\SQLINSTANCE like Data Source=EPOS-SERVER\SQLEXPRESS
OR
Data Source=IPADDRESS\SQLINSTANCE like Data Source=192.168.1.5\SQLEXPRESS
OR
Data Source=localhost\SQLINSTANCE when DB is hosted on same machine

Is 49170 your instance or are you trying to use non standard ports?

Yes it is happening when I try to start the SambaPOS from client PC. And I am sure I installed SambaPOS V5162 in both client and server.

I followed this tutorial to create the instance.

So I use the 49170 as an instance.

Where you get that from - tutorial has SAMBAPOS as instance.
Either way connection string is backslash instance not comma?

Sorry I forget to give you another tutorial link from youtube.com which I followed. That was…
https://www.youtube.com/watch?v=5UkHYNwUtCo

It’s a non samba tutorial so not going to be 100% applicable.
Ice ever tried setting a non default port, emire might be able to offer sugestion but is there any other reason you opt for that port?
SQL setup is well documented on forum so why not follow a tutorial you know works…

I also got this in Samba forum. So I accept this and SQL Server already connect using this port number.

But if you doubt about this I will try the way as you suggest me. Please give me a solution.

It connects to SQL but it tries to ALTER tables to migrate. If they are both .62 maybe you’re trying to connect to a database file SambaPOS actually use. How connection string configured on server?

1 Like

Thanks Emre,
You are right. I made a mistake in the connection string in the client pc. In client pc I gave the name of a Samba4’s database (gpHouseData). But the actual database name was “testData5” which I gave in the server PC. Here attached the screen shot of the server connection string.

You are great Amre!
Thanks again

Hello Emry,
Now I am facing a new problem that when the anti-virus is turn on in server, client can’t connect with the server. After turn off the anti-virus and restart the server client can be connected. But the Anti-virus is necessary for the server.

So how can I solve the problem?

In your anti virus put message server and sambapos as an exception so it bypasses the filters in place. Also make sure your firewall is configures correctly

1 Like

I quote:E.g. if server ip is set to 192.168.1.2 then you would put in client pc… 192.168.1.2,49170.

Do i have to install the SQL Express on the Client PC as well?

No.

SQL Express should be installed on the “server” Terminal only. It should not be installed on other Terminals.

The same goes for the Messaging Server Service: it should be installed on the “server” Terminal only. It should not be installed on other Terminals.

1 Like

Thank you for the reply, lastly, how do i see if the client is connected to the database?

You will know the Client is connected when you can Login on the Terminal and see the Menu.

You should only follow tutorials that are related to SambaPOS