Login using MSR

Hi, I LOVE the program!!! I was wondering if there is a “how to” post on using MSR (magnetic strip reader) to login into the program? I have been searching, but have not found anything. I would like for my employees to login using their cards. Right now they type in their numeric digits to login, but i think the card would be faster and more privacy for the workers. Any help on this would be great!!! Thanks for all your hard work!!!

Any card reader will work, but you need to have the cards programmed with a unique id.

RFID readers are faster to use and the tags already come with unique id’s, be it hexadecimal, but they work well as no one knows the code.

Just search the forum for “RFID”

1 Like

John, thanks for the reply, is there a tutorial where I can setup the pos system? I have an elo touchscreen monitor that came with a card reader and I would like to take advantage of it.

It’s just like using a barcode scanner. Plug and play.

Open Notepad and swipe a card. You should get some text appear. You can even test with a credit card.

Card swipes can read 3 tracks from the cards. There should be some software from ELO to help configure the card swipe to only read one track and also configure pre & post suffix for each track.

John, I got that far. My question is how to i set SambaPOS to allow me to input the ID numbers for each staff members? This is where I am stuck right now. I am able to test the MSR and it works fine, but I don’t know how to setup samba to login my staff when they swipe their card. Thanks for the quick replies.

There is no setup. Got to each user click on Pin and swipe their card to set the Pin.
Logout and swipe a card to log in.

1 Like

awesome, working great!!! Thanks John for all your help!!!

Hi John,
Am trying to add a MSR reader to a terminal with pc and touch screen.
Purchased a usb reader from ebay which reads the test pin 1234 (obviously ;1234? output in textedit).
It drops to next line when testing in text edit however doesnt seem to enter on samba login?
Am a little lost, if I swipe on samba it inputs the 4 digits but doesnt login, if i hot enter on keyboard or on screen it will log in so is corectly receiving the 1234 however isnt loging in.
As I said a swipe in text edit drops for to next line after so not sure why its not loging in.
Have tried writing the pin to track one and to track to, no difference.
Have writen some cards for another place with a built in reader which worked ok. :-/
The reader shows in devices & printers on win 7 as keyboard.

Is there an extra setting you need to add after the number that tells it to “press enter”

I know for barcode scanners sometimes there is a setting that has to be activated that has the return function at the end so after number is read it “presses enter”

I know you said when you swipe it drops to the next line but that obviously isnt acting as the return function to enter the number, perhaps theres another setting needed to be activated from the msr driver/software?

Just quickly googling msr readers the first couple i looked at talked about needed to set the carriage return which is what i think yours is missing. I guess this is in your device settings somewhere, some even say that the carriage return symbol used for a particular device is /r

Hope that helps

Thanks, think I found similar results on google.
Think it’s the carrage return
OR allot of talk regarding HID or hey board emulation.
Any ideas which is needed for samba.
I have checked the spec of my msr and it says it does both but can’t find a config app to change.
Looking in device manager it seems to show as both so might try disabling one and see if that helps.
Have emailed manufactur to see if there is a config utility.

1 Like

Hi @JTRTech, sorry coming in a bit late here and I only just skimmed the thread but @JohnS is correct. MSR’s are just like extended keyboards stuffing characters into the keyboard buffer. All these devices work independently from SambaPOS and hence normally you configure outside of your Software and use something like notepad to test.

I configured heeps and only purchase the ones which come with a configuration utility, Typically the utility will allow you to change:

  • Carriage Return/LF at the end of READ
  • Carriage Return Only at end of READ
  • READ Tracks 1/2/3 (Mag Cards can have 3 tracks to store different data i.e Employee ID Track 3)
  • Charcter Set
  • Beep on READ
  • Beep Loudness
  • End Character after READ i.e. the “?”
  • Start Character on READ i.e. “%” - IMPORTANT as some POS like to have a starting character to tell it to search for a Customer or Employee i.e. You may use “%1234” for Employee and “$1234” for Customer.

There are more settings but above are the main ones I use. Moral of this note is always buy a MSR USB reader which comes with a config utility program. Also there is a good chance the manufacturer/supplier can send you one as I been in the exact position a few times.
Hope this helps, Paul.

I now have the config utility however still cant get it to work.
I have all the options you listed but still cant get samba to recognise the carrage return.

Have option of CR+LF and CR and have tried both.
Have tried disabling the SS and ES but dont think it matters as samba login only recognises numericals.
This really has me stumped.

I have noticed int he text box that just CR does not drop to new line where as the CR + LF does?

CR doesnt seem to do anything,
if i say open internet and in url box swipe i get the card data but doesnt try and go to that page, hitting enter on keyboard will. ;-/
Likewise on login screen of samba, pin it input but no enter, enter on keyboard will login after swipe


a bit more tinkering and now seems that i have got CR setting in utility to drop to next line.
changes the keyboard type to US rather than UK, or at least think thats what did the job.
now in notepad i get a drop to next line with only cr turned on however samba still doesnt seem to pickup the return after the pin :-/

interestingly now i have put back to CR + LF and now in notepade get two new lines after pin entry on swipe but still no login on samba :frowning:

dont understand what im doing wrong, pulling my hair out trying to solve.

@JTRTech you are very close and I do not understand if you get a “1234” + in Notepad why do you not get the same in SambaPOS? At this point you may need to ask @RickH or @Jesse as possibly the Login routine requires something else at the end of the PIN?

Typically configure -> Test in NotePAD (or other text editor) -> Use in Application as long as the Application has a entry screen to accept output i.e. SambaPOS login.

Nothing else required. Carriage return after pin should be enough.

I am convinced it has something to do with HID keyboard vs keyboard emulation.
Many other msr readers refer to changing between them.
The spec for mine say both for interface and in device manager I get 4 listings, 2x usb input, HID Device and a keyboard entry.
The config utility doesn’t give an option to choose
Have tried disabling the HID entry and the keyboard entry to see if any difference but neither resolve the issue.
Other pos software specify recquirmet for HID or emulation but can’t see a msr spec for samba.
My only understanding of the difference is presumably one shows exactly as keyboard as far as system can tell but the other outs puts keystrokes as code :-/ - this is probably wrong but kinda makes sence,
Samba picks up on the numbers but not the return which note pad etc does line wise and presume samba needs to think the enter key is pressed.
Have contacted the msr seller and the manufacturer and awaiting response.

What model of msr do you have in use?
Have seen a job lot of magteck msr online I may buy for now as system needs to go live very soon and msr is a big factor of speed and usability.


Just a thought JTR - do you have anything specified as ending character? This should be BLANK i.e. 1234? or 1234! is incorrect it should just be 1234 and then tell the MSR to add at end of the Read.

PS: Most of my units come with the POS Hardware but I always request Config program.

I have tried turning on and off the SS and ES to no avail, am going to try taking it to another place and see if it acts any differently there encase I have changed anything on os install as stripped out allot of excess windows parts which are unrequired for till.

I do not add a ending ?, as I understand it a writer will put these in automatically as part of the msr iso standard to desperate lines however the config utility gives the option as to show these or not.

If you like can you open Notepad and swipe a Mag Card 3 - 4 times without touching the keyboard and show a screen grab here of the output? Just interested to see what it looks like.