Metrik mobile reporting app



I’ve also done everything but not receiving any data on the App. I’ve checked the windows services but can’t find the

you’ve referred too. I only have SambaPOS-MessagingServer which is running as you can see below.

And yes I did run the SambaConnect.exe application which was downloaded through SambaPOS.
Is there something or step I’am missing?


That service is old do not mind what I said it’s false info now. Did you scan the QR code in Sambapos?


Yes, I did scan the QR code.


You try turning windows firewall off? You do have data for current day?




Uninstall SambaPOSConnect and reinstall then generate and scan QR code again.


Won’t even generate a qr code in my installation, tried uninstalling and reinstalling, just get get connection error.
The app does not allow the manual input of the code (contrary to the kb guide).


Uninstalling sambaposconnect? Surely your not meaning sambapos


No just the connect app


So you dont have a QR code on your screen when you go to Metrik tab in manage screen of sambapos?


Correct installs sambaconnect runs the program, when I click on generate qr code it shows error connection fail. Tried to manually create a qr code which metrik recognises but does not pull in any data.


You have Internet access right? Your using full sql version or localdb?


Yep internet access is fine (fttp) full SQL installed, 1 pc acting as server + 1 touch screen terminal,.
Samba database and sambaconnect installed on main pc (server) running Windows 10. Ports are open in firewall.
To be honest it would have been nice to trial metrik but not a necessity for my setup.


I have no idea then @tayfun


@KryptonFactor please completely disable firewall or antivirus software and try again.


My QR code takes about 15 min to generate. Is this normal? System resources are not taxed but it seems a bit excessive. Anyone got this problem?


No data for me also, 0. I tried everything you told here :frowning:


Show screenshots it’s hard to help without them.


Metrik working well still so far , what i noticed is open is showing open table numbers , its not showing other open tickets like customers, takeaway departments .
I guess should change to open tables or get all open tickets .


It counts only tables now. But we are working for other tickettypes