SambaPOS 5.1.62 Release


#43

No, it means SambaPOS has identified issues with some of your Rules (4 problems). The Popup is a new feature, but the [Test Rules] link has been there for a long time; most people don’t know what it is for and never use it.

The tool will detect even the smallest of things, like unmatched case-sensitivity.

Check the Action for Change Order Price and you will probably find that [:Price] is instead configured as [:price] (lower-case ‘p’) for example, or it might be completely different.

I had a few Actions with that “issue”, but they still worked fine. But if you want to suppress the Popup, you need to fix the problems. So if you change the parameter in the Change Order Price Action to [:Price] (upper-case ‘P’) and run the [Test Rules] check again, you should get a result of “Test completed without issues.” This is because all of your detected issues relate to the same Action parameter and can be fixed with a single change.


#44

No nothing changed. There are issues with your rule configuration and SambaPOS notified it. Isn’t it clear enough? I’m asking to understand how I can better explain that.


#45

i like this tool to test the rules.


#46

Sorry @emre, i did not mean that it was not clear… I tought that maybe the rule processor had some improvements, and that some of my rules may not behave as ussual…

sorry…

either way…
I am confused…
I get those 4 warnings… but cannot find the issue

G.


#47

Do you have another action with same name?


#48


#49

Sorry… Do you have another action with “Change Order Price” name?


#50


#51

@gerlandog, show your ACTION list, like Emre is asking for. NOT the Rules.


#52

sorry… I was looking at the ACTION word, saw it selected… and did not think any further… my apologies

so… Emre nailed it…

Two actions with the same name… but under different actions… could that be the problem?

G.


#53

Yes, that is a problem. You should never have 2 Actions of the same name. I think that is prevented in later releases.


#54

OK… now the nightmare starts… LOL

will try to find out how to find wich one is firing and when… and then change the name…

THANKS!!!

sorry for the trouble.

G


#55

Ive got a few “errors” to go through, i cleared some last night where i must have change the name of an action whilst it was still in use so i had a load of rules saying the action in those rules did not exist, so i had to find the correct action and swap them out

Really handy little feature, just got about another 20 errors to work through now haha


#56

I uploaded another update.

https://sambapos.com/?wpfb_dl=163

  1. Preventing multiple actions with same name.
  2. A Price List Editor issue that leads to incorrectly updating additional prices fixed. Product name column docked to left for easier scrolling horizontally.
  3. “Start Message Server Now” button replaced with “Test Message Server Connection” button for easier message server connection setup.


#57

Hi emre,

while i download the latest update release hit below error:


#58

Hi Byrant that problem solved. You can download.


#59

Got it. Thanks for the fast reply.


#60

Why after i upgrade to this version 5.1.62. Computer after end period become unregistered trial again.
I make backup each day when end period. I save backup file at local disk. OS win 7 home.
Computer does’t internet connection at daily operation. Just when i activate samba i link to personal hotspot from my phone.
I had done.
Clear license at sambamarket and activate again.

It happen 5 times
No error log happen.

My other customer use win 10 not get this problem, just at win 7.


#61

Because user do not wait backup operation to complete (because he’s probably does not aware of it) and just shutdown the computer. On next update I’ll display an indicator while it creates the backup.


#62

It displays that indicator already @emre