SambaPOS 5.2.14 Release


#1

:arrow_down: Download: https://sambapos.com/?wpfb_dl=203

:warning: Don’t forget to create a backup before installing new releases. You’ll need a working backup if you need to rollback to previous version.

What’s new in 5.2.14

  • Ticket / Order / Order Tag details printer tags added
  • Logging for scale devices added.
  • Auto select fixed for custom menu item buttons
  • Printer tag for reading order tag quantites added
  • Weight barcode checkdigit issue solved.
  • Add more logging to scale device.
  • Toggle order selectors added
  • Keyboard sizing for account document creator fixed
  • Paid item order matching fixed
  • Select payment orders action implemented
  • Adjust order prices action implemented
  • Order tag amount field added
  • Save to PDF Custom Printer implemented
  • Style support for HTML printer added
  • HTML printer table margin issue fixed
  • Improve price adjuster sorting items
  • Colors cached for faster brush creation
  • If no header defined menu item buttons grabs header from menu item
  • Percent discount for x items. (Promotion enhancement)
  • Refresh Order Tags command for Execute Ticket Command action.
  • Sorting function improved for adjust order prices
  • Optionally distribute discounts for adjust order prices.
  • Apply calculate price filter after untagging discount tag
  • Handle voids for order price adjuster
  • Expression to filter by account id added for Report Account Transaction Details report.
  • Prevent exception if HMTL format BAR tag is empty
  • Change automatic padding to zero for flow document printer.
  • Prevent message region to capture focus.
  • Screen menu item error fix.
  • Decimal order tag quantities.
  • Empty navigation when there is no work period created issue solved
  • Default HTML Ticket tempate added
  • Update Task action added
  • Custom report grouping improved
  • Crash on null currency issue solved
  • Custom report viewer updated for better handling selections.
  • Report Open Tasks custom report added
  • Missing fields added for order tag data export
  • Widget Optimizations
  • Date Picker for Report Viewer added
  • Virtual Keyboard problem fixed
  • Reservation added
  • Rules modified to allow work with tickets after save through gql
  • Improvements to manage rule state
  • Display remaining days on beta indicator.
  • Auto message server discovery improvements
  • Order Price calculates properly for combos
  • Reset selection cache or select orders action
  • Expressions for Select Orders action
  • Ignoring Order Tag prices and portion prices for adjust order prices.
  • Display correct order’s details when order is splitted
  • Automatic Foreground color for label widget.
  • Disabling allow past dates for date editor widget.
  • Min and Max values for editor widget.
  • Grouping Editor Widget Settings.
  • Field for fetching price with price tag with fall back to default price.

SambaPOS 5.2.13 Beta Release
Receipt printer margins problem with Document Printer
#2

#3

Noticed today that after installing this update my servers can no long print their own read from a button I put on my tables entity screen as they don’t have management permissions. It works if I’m logged in as Administrator so I tried checking every box under the “server” role and still didnt work so I clicked the “Admin box” under the General Settings and it worked. I don’t want to have to give them Admin permissions but I’m stumped on what to next!


#4

They don’t need admin they need reports permission.


#5

They’ve always had it. I checked every box under Permissions and it still prints with an Asterisk where it should have the servers name.


#6

If it’s putting an astriks that means they are not logged in. Do you have some autologout automation ?


#7

I do… 1538523367008495589158456765696|690x517
Apologies for the picture but I’m not there anymore. Shouldn’t it print read before it logs out though?


#8

Sorry


#9

Check what it shows fir user name in bottom right. Does it show an asterisk there?


#10

No, @kendash is right. If I remove the Logout User action everything is fine. I just don’t understand what changed and wht the print read action doesn’t fire first. …and whats with the Async check box?


#11

It probably doesn’t have time to finish before logout.


#12

@emre thanks for the fix!


#13

What you’ll need to do is:

  1. remove the logout action from that rule
  2. Add an auto command action with delay action instead
  3. In the auto command action put “Logout With Delay” as the auto command and enter a delay of 1 (for 1 second)
  4. Create a new auto command executed rule with auto command name equals “Logout With Delay”
  5. Add your logout action to the rule just created

This happens sometimes with auto logout as the system doesn’t have time to process other things whilst logging out so we need to delay the logout slightly

By doing the above it will delay the system logging out by 1 second, giving the system time to process other background functions and print your reads before logging out

If it still doesn’t work change the delay from 1 to 2 seconds and try it again


#14

Execute print job starts working after all rules executes. Enable “High Priority” setting to make it work at the moment it called.


#15

You can also capture the “last user” to a ticket tag each time ticket is opened / created, then use the ticket tag in your receipt instead of user. This is the way we get around it. I’m surprised you only experience this * now, we have experienced it for as long as I can remember when using auto logout.


#16

whats up with the new async check boxes for actions in rules? I am already seeing it help me with development for implementing order tag note setup but not fully understanding how it works. Can someone explain it please?


#17

@emre Just tried to Clone a Menu. I get the following error:

-----------------------------
[General Info]

Application: SambaPOS
Version:     5.2.14
Region:      en
DB:          SQ
Machine:     POS1
User:        EPOS User
Date:        04/10/2018
Time:        22:53

User Explanation:

EPOS User said ""
-----------------------------

[Exception Info 1]

Top-level Exception
Type:        System.Reflection.TargetInvocationException
Message:     Property accessor 'WrappedCaption' on object 'Samba.Domain.Models.Menus.ScreenMenuItem' threw the following exception:'Object reference not set to an instance of an object.'
Source:      System
Stack Trace: at System.ComponentModel.ReflectPropertyDescriptor.GetValue(Object component)
   at Omu.ValueInjecter.ConventionInjection.Inject(Object source, Object target)
   at Omu.ValueInjecter.ValueInjection.Map(Object source, Object target)
   at Omu.ValueInjecter.StaticValueInjecter.InjectFrom[T](Object target, Object[] source)
   at Samba.Infrastructure.Data.Injection.EntityInjection.SetValue(ConventionInfo c)
   at Omu.ValueInjecter.ConventionInjection.Inject(Object source, Object target)
   at Omu.ValueInjecter.ValueInjection.Map(Object source, Object target)
   at Omu.ValueInjecter.StaticValueInjecter.InjectFrom[T](Object target, Object[] source)
   at Samba.Infrastructure.Data.Injection.EntityInjection.SetValue(ConventionInfo c)
   at Omu.ValueInjecter.ConventionInjection.Inject(Object source, Object target)
   at Omu.ValueInjecter.ValueInjection.Map(Object source, Object target)
   at Omu.ValueInjecter.StaticValueInjecter.InjectFrom[T](Object target, Object[] source)
   at Samba.Infrastructure.Data.Serializer.ObjectCloner.EntityClone[T](T item)
   at Samba.Presentation.Common.ModelBase.EntityCollectionViewModelBase`2.OnDuplicateItem(Object obj)
   at Microsoft.Practices.Prism.Commands.DelegateCommand`1.<>c__DisplayClass6.<.ctor>b__2(Object o)
   at Microsoft.Practices.Prism.Commands.DelegateCommandBase.Execute(Object parameter)
   at Microsoft.Practices.Prism.Commands.DelegateCommandBase.System.Windows.Input.ICommand.Execute(Object parameter)
   at MS.Internal.Commands.CommandHelpers.CriticalExecuteCommandSource(ICommandSource commandSource, Boolean userInitiated)
   at System.Windows.Controls.MenuItem.InvokeClickAfterRender(Object arg)
   at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

Inner Exception 1
Type:        System.NullReferenceException
Message:     Object reference not set to an instance of an object.
Source:      Samba.Infrastructure
Stack Trace: at Samba.Infrastructure.Helpers.Utility.Get2Lines(String input)
   at Samba.Domain.Models.Menus.ScreenMenuItem.get_WrappedCaption()

-----------------------------

[Assembly Info]

mscorlib, Version=4.0.0.0
Samba.Services, Version=1.0.0.0
Samba.Domain, Version=1.0.0.0
Samba.Infrastructure.Data, Version=1.0.0.0
System.ComponentModel.Composition, Version=4.0.0.0
Samba.Presentation.Services, Version=1.0.0.0
System.Core, Version=4.0.0.0
PresentationCore, Version=4.0.0.0
WindowsBase, Version=4.0.0.0
DevExpress.Xpf.LayoutControl.v16.2, Version=16.2.13.0
System.Xml, Version=4.0.0.0
DevExpress.Xpf.Grid.v16.2, Version=16.2.13.0
System, Version=4.0.0.0
DevExpress.Xpf.Grid.v16.2.Core, Version=16.2.13.0
System.Xaml, Version=4.0.0.0
PresentationFramework, Version=4.0.0.0
Samba.Infrastructure, Version=1.0.0.0
Microsoft.Practices.Prism, Version=4.0.0.0
System.Runtime.Serialization, Version=4.0.0.0
Microsoft.Practices.Prism.MefExtensions, Version=4.0.0.0
DevExpress.Xpf.Core.v16.2, Version=16.2.13.0
System.Windows.Forms, Version=4.0.0.0
System.Drawing, Version=4.0.0.0
Samba.Persistance, Version=1.0.0.0
Stateless, Version=1.0.0.0
PropertyTools, Version=2012.4.14.1
Samba.Localization, Version=1.0.0.0
ReachFramework, Version=4.0.0.0
EntityFramework, Version=6.0.0.0
FluentValidation, Version=3.4.0.0
Microsoft.CSharp, Version=4.0.0.0
Omu.ValueInjecter, Version=2.3.0.0
Microsoft.Practices.ServiceLocation, Version=1.0.0.0
DevExpress.Data.v16.2, Version=16.2.13.0
NCalc, Version=1.3.8.0
WindowsInput, Version=1.0.4.0

-----------------------------

[System Info]

Operating System
-Microsoft Windows 10 Enterprise 2016 LTSB
--CodeSet = 1252
--CSDVersion = 
--CurrentTimeZone = 60
--FreePhysicalMemory = 2427328
--OSArchitecture = 64-bit
--OSLanguage = 1033
--ServicePackMajorVersion = 0
--ServicePackMinorVersion = 0
--Version = 10.0.14393

Machine
-POS1
--Manufacturer = Default string
--Model = Default string
--TotalPhysicalMemory = 4106600448
--UserName = POS1\EPOS User

-----------------------------


EDIT: Checked all menu products have a “Name”. Only thing odd is I noticed some categories, “Sort Order” is set to 0 on all products, not sure how that happened since I haven’t touched the sort order.

EDIT: I’ve went through and selected then saved “Sort Category Products” on all those categories with 0 sort order so they all had “correct” values in place. Tried to clone menu again, same error and crash.

UPDATE: Ok, this is not only my setup - I get the same error and crash on a fresh sample database if I try to clone the Menu. I can reproduce it on 2 different systems.


SambaPOS 5.2.15 Beta Release
#18

On 5.2.14 “if no header defined” changing Product name will change Menu button caption automatically. I think that issue relates with that feature. That works fine for me as I’ve recently changed “Caption Wrapping” feature so I couldn’t reproduce it but it will work fine on next update.


#19

I created a new topic for 5.1.15 Beta Release and uploaded a fresh build. Thanks.


#20

Getting a bit ahead of the rest of us @VehbiEmiroglu :wink: