[SOLVED] Caller ID not working on v 4.1.43

dear @emre.
After the upgrade to version 4.1.43.
Caller ID does not display PopUp.
What could be the reason?
I checked in putty and it shows the number correctly
I tried to see if it works in a previous version
And it works great.

Can you show me the output of putty? so I can tell you how to update your setup.

Can you try typing NMBR.*=?[^0-9]+([0-9-\s]+) to Match Pattern setting of generic modem?

If it does not work try one of these and please let me know which one works.

  • NMBR.*=?[^0-9]+([0-9|-|/s]+)
  • NMBR.*=?[^0-9]+([0-9]+)

NMBR.*=?[^0-9]+([0-9|-|/s]+) working.
thenks emre

Can you do me a favor and test if NMBR.*=\s?([0-9-\s]+) works or not?

Also works
What is the difference between them?

Thank you very much. It covers more cases. I’m trying to set a default value to handle both spaces,dashes in numbers and additional spaces around = char.

1 Like

Thank you so much emre

Dear @emre if a phone number starts with 0 for example 0612345678 I noticed that in the CID popup sambaPOS shows the number without the 0, so it gives me 612345678. Is there a way to display the number including the 0.

Removing zeros is configured by Trim Chars setting. Change +90 to + so it will only trim + char.

1 Like

@emre first day it was working fine but since I backup the data restored since caller id not working yesterday I tried the first seting in putty working fine , but today I restarted pc but not working any more even I tried second one( putty Showing Caller id after 1st ring everytime no problem in putty) iam using k v.92/v.90 usb2.0 fax modem need help thanks