Using notepad as a printer in V4.1.47

I recently started to evaluate Sambapos with v4.1.44 in text file mode (TX) and had a demo printer (notepad) set up and it was working fine. Before setting up the production system I decided to download the latest version of Sambapos, V4.1.47 as well as setting up MSSQL express 2012 and I now can’t get this to print anything to notepad.

I have set up a new printer as follows

Printer name: Test Printer
Printer share name: …
Printer Type: Demo Printer/notepad

All other settings left as default.

I have then modified the Print Jobs > Print Bill to add an additional mapping to Test Printer, but I am getting nothing printing at Notepad (which is left open).

I am fairly sure this is exactly what I did for v4.1.44 and it worked fine. Can anybody shed any light on why it doesn’t work now / what I am doing incorrectly.

Thanks for your help.

What are you trying to print? I’m using 4.1.47 and it prints to notepad just fine. It could be the Print Bill Action in your rule is setup wrong?

Thanks for the reply. I haven’t changed any of the actions/templates from the default setup. What should I be looking for?

Does your actual printer give you output… or are you just testing right now?

If your wanting a customer receipt on payment add an Execute Print Job action put Print Bill as job name everything else default create a Payment Processed rule with the constraint Remaining Amount Equals 0 add your action you just made
Make sure your print bill job template is mapped to ticket template

At the moment I do not have a real printer attached, I am just trying to set up the system.

I have (from the default setup)

Action name: Execute Bill Print Job
Action Type: Execute Print Job
Print Job Name: Print Bill

Rule Name: Print Bill Rule
Event Name: Automation Command Executed
Execute Rule If Matches
Automation Command Name Equals Print Bill

I have added Remaining Amount Equals 0

The Print Bill Job Template is mapped to the Ticket Template

But still nothing in Notepad

You need to make a new rule… it should be Event Name Payment Processed

The default setup does not print a customer receipt on payment you have to add that. To edit how the receipt looks go to Settings - Printer Templates - Ticket Template There are several guides in the Tutorials section of this forum that explain how to format tickets using the strings listed with the helper portion of the template editor.

That is good to know however, at the moment I am just trying to get it to print something when the Print Bill button is pressed. This worked fine in the default setting when I used v4.1.44, so I would have expected it would now.

can you give me a screenshot of the Print Bill Rule your using I just tested it using the Button and it worked just fine as well.

Ok I figured it out. I don’t know if its a bug or just how its intended but you mentioned that you added a new printer… so I assume you still have Ticket Printer mapped and under that you have your Test printer mapped. The Ticket Printer is not mapped to a share name or port… so it looks like its getting stuck at the print job there and not sending it to the demo printer.

Just delete your test printer… change the Ticket Printer to use notepad and it will work… When you go to production just change ticket printer back to your printer type and your actual share type.

Or keep your test printer… but take the mapping to the ticket printer out of Print Bill Job and just add it back when you go live and remove your test printer mapping at that point.

I just ran some more tests. You can have both mapped but if one of them is not an actual printer or Share name/Port is not real the printer that’s set to print to notepad has to be the first printer mapped under Print Bill Job.

It appears that if you map multiple printers to a Print Job but the first printer mapped is not a real printer and is not a demo printer it will not print to the rest of the mapped printers. But if the first printer that is mapped is a real printer and has an actual Share/Port to send to it will go ahead and print to the other mapped printers.

I also thought that may be the problem and tried it earlier. I have gone through it again, removed the test printer and removed the additional mapping completely and set the ticket printer Type to Demo Printer (Notepad). In the database the ticket printer now shows as type 4 which suggests all is good.

Unfortunately, still no output at notepad.

The reason I had the share name on the Test Printer as … is that in Emre’s printing tutorial it says “Enter a dummy Printer Share as . or something similar, not to leave it empty”

You have to have something in the share name for the demo printer to work. Try putting a single . in the share name for ticket printer and set it to Demo/Notepad and make sure its the only printer mapped

I just ran multiple tests with all the scenarios i just mentioned and everything I just said in the above post was true.

Still no joy sadly

I dont know then I cant seem to duplicate your issue unless it was the issue I already mentioned I was able to replicate it then.

At what point are you pressing the Print Bill button?

Maybe show us your Ticket Template?

I am pressing it at the point a customer would have requested the bill.

Ticket template is the default at setup

– General layout
Ticket No:{TICKET NO}

[Total Gift:|{ORDER STATE TOTAL:Gift}]




– Default format for orders

– Format for gifted orders

– Nothing will print for void lines

– Format for order tags

– Table entity format

– Customer entity format
Customer: {ENTITY NAME} | {ENTITY DATA:Phone}

As far as I can see, the only things that are different from when I had this working in v4.1.44 (apart from the version) is that I know have a proper database and I have played around with the screen layout (see screenshot) to try and determine the best way to present everything

It could be a database issue but I am not sure… It should work. Its working fine for me other than the issue I explained about multiple mappings.

Maybe try reinstall fresh setup and start with fresh database.

I would doubt it is the database. I can see all the transactions in the database and if I check in reports I can see the reports correctly.

I have just tried printing the report (I hadn’t thought of that previously) and it prints to notepad fine, which suggests the printer is set up correctly so I guess the problem is something to do with the command from the print button