Different menu Layout for Tablet with RDP

I want to have different menu layout on the Tablet I am using with RDP. The main reason for this is the scrolling problem. I aranged my menu in such a way so that it fits perfectly on the Tablet screen , but it doesn’t look good on the screen of the PC.

1 Like

You can map different Menus to different Terminals.

1 Like

I managed to solve the problem myself and I am sharing my solution. Here it is:

  1. Go to to Products-> Menu List-> Right Click on the Menu -> Clone Menu -> Name it Tablet
  2. Go to Settings->Departments-> Create New -> Name it Tablet->Choose Default Menu Tablet
  3. Go to Users -> Role List-> Create New -> Name it Tablet -> Choose Department Tablet
  4. Go to Users -> User List-> Create New User -> Name it Tablet - > Choose Pass -> User Role Tablet
  5. Go to Menu List -> Tablet - > Edit Menu Properties (Here you can change the view of the categories- Column Count) - > Edit All categories (Choose the layout of the products inside the categories)
1 Like

Another question. Is it possible for changes to the screen entities to refresh right away between devices? When I mark products on the pc I have to open a table and close it to see its state changing.

Have you started the message service on one of the machines (the sql hosting one typically) and then pointed the other divices to this machine in the message server settings?

1 Like

No. I use RDP with an Android Tablet.

Yes but RDP to what??? The RDP machine will still need samba to be looking to a message server!

The RDP machine is the Server. I RDP into as a second user.

You must use Message Server for this to work. RDP doesn’t magically negate this requirement.

1 Like

I followed the guide and now on the tablet there is a green text Connected. But the state doesn’t change when I enter new information on the tablet or on the server.

OK so on tablet all you did was type in message server name or ip? And on your server you started the service?

Yes. I followed all steps in the guide. The server works and on the tablet screen there is a happy green message Connected. If I play with the settings it says Can’t Connect to Message Server.

So show us a screenshot of your message server settings on the tablet. Did you install message server as a service on the server?

Here is the Message Server running on the main account:

Here are the settings on the client side. It is accessed trough a second account on the same physical machine.

What version of SambaPOS you using?
V 60 and later should use http://your server_name and port 9000. Messenger service port 9000+

I am using V5. Can you explain what you mean? Why should I change the port? It seems to connect, but it doesn’t work.

I don’t need to know why. I only need to follow instructions and it works. I don’t care why.

Emre explained why you must have ignored that part the extra configuration is for gql if you use it. If you don’t then it works as before and no + sign required. So no this is likely not the issue

Open port 8383 in your Windows firewall.