How to migrate from V4 to SambaPOS V5

Hello Samba Club Community Team,

We wish to upgrade our old SambPOS v4 server to a new machine & SambaPOS v5.

OLS System
Currently we have
Windows 7 64 bit
SQL Server 2012
SambaPOS v4 App 4.1.8 [SQ]
I cannot do a backup of samba from within SambaPOS v4 because backup is not available
SAMBA Market does not have the Database module available
I can do a backup of SambaPOs from SQL Server 2012
It then creates a SambaPOS4.bak file

We are about to Purchase SambaPOS V5

New System
I have installed SambaPOS V5 in trial mode
The new System has SQL Server 2017 express
With Microsoft SQL Server Management Studio 18

Please recommend the best way forward, To bring the new system online with

The old SambaPOS4 Data…

P.S. Restore is easy in SQL Server, but upgrade and database connect to system is

Regards Troy

The KB has some steps for the upgrade; it looks relatively painless

Once you restore the backup from within SSMS, be sure to change the compatibility level to your current SQL version (there have been a lot of updates from 2012->2017)

These posts may also be useful:

unfortunately i cant do STEP 0 because.
I cannot do a backup of samba 4 from within SambaPOS v4 because backup is not available
the backup app is not available to me in the Store?

Team, is their anyway we can purchase the old version 4 tool that was available on the Samba Market to assist us in the backup of SambaPOS v4

any suggestions on this please.

You can do a backup using SSMS. Right click on your database, select tasks, then backup


yes i am able to do that… that part is done :slight_smile:

I have just installed SambaPOS v4 on another old Win 7 machine and just had a look at the
Samba Market, the database backup tool is available their, Why would it not be available in the
fully registered version ?

V4 is not supported anymore, compared to V5 and everything that’s available there, V4 is more like a proof of concept than a professional version. You are very unlikely to get any support for V4 here as most of the users haven’t used V4 in a very long time.

V5 has all the tools and few more in SambaMarket already “embedded” into it.

I couldn’t tell you as I’ve never used V4.

I think the easiest way to do this would be install V4 on your new machine and have it create the default database with the name SambaPOS5. Then from within SSMS restore your database. Uninstall V4.

Set compatibility level as such:

Then install V5, configure it to point to SambaPOS5. Restart SambaPOS5 and then follow the steps from the KB/posts

1 Like

After you restore the database (use a different name) and just change your connection string to that database in V5. Normally it will take it few moments longer to boot because it will be making updates to the database.

Once you are in, you can use Program Settings > Maintenance to Update old Rules and few other things if required.

It was a long time ago I did this and as far as I remember it was pretty much seamless.

I have done the SQL database backup…
but when SambaPOS is backing up the file it returns the following error…

Execution Timeout Expired. The timeout period elapsed prior to completion of the operation or the server is not responding.

i have tried it in 3 locations and all 3 have read write access.
and the Drive is solid state…

So the backup is completed. Did you perform the migration? When you talk about SambaPOS performing the backup are you using v5?

If it were a write access issue there is a separate dialog that would say.

Is there anything at the tail of the log file?

I have done the SQL database backup… :white_check_mark:
but when SambaPOS v4 is backing up the sql sambapos4.bak file, trying to build the file, it fails and returns the following error… :negative_squared_cross_mark:

“Execution Timeout Expired. The timeout period elapsed prior to completion of the operation or the server is not responding.”

i have tried moving the sql sambapos4.bak file to 3 different locations and all 3 locations have full read write access.
and the Drive is solid state…

unfortunately i left the site before getting a chance to see the log file.

So you have the v4 backup (.bak file). If you zip that and place it in the backup folder that v4 is using you should be able to restore it.

Something to try, zip the .bak file and place it in the v5 backup folder and see if you can restore it. It may work. Then when you’re logged out, restart SambaPOS v5.

If it’s a large db the underlying framework may not allow the SQL command to execute as you can see it’s timing-out.

Just install backup module and run backup in trial mode. You’ll get activation popups but will work fine.

Hello Team,
Here is the Update…
Old Server Win 7 Pro
Run the Backup in SQL Server 2012 management studio.
With SambaPOS V4
Created the PosServerV4.bak file
I turned on the Backup module in trial mode again in version 4 on the old server.
Pointed the path to the *.bak file location.
Failed again.
then I used winzip to zip the file up as was recommended.

copied both the PosServerV4.bak and the
to the new server.

Win 10 Pro
SQL Server 2019
SQL Server 2018-19 (18.8) management studio.
With SambaPOS V5

Started PosServer V5 activated the backup module in trial mode.
pointed to the file location.
then ran the restore from backup.
Finished successfully

Closed SambaPOS and reopened with the normal admin password. (Not 1234)
looking great so far…
Then Checked that its running from the New SQL Server
All Good )

Then installed SambaPOS Version 5
on the old workstation computers with windows 7 that are currently setup to use SambPOS V4.

I ran SambaPOS Version 5 but no matter what i did it could not connect to the POSServer

It kept on saying fix the connection to the DataBase.

I had a spare windows 10 workstation, the moment I installed SambaPOS Version 5

And started SambaPOS Version 5 it detected the SQL data on the network.

Please can anyone recommend a fix ? or an idea as to what could be happening… ?

So you’re trying to connect the old W7 terminals with v5 to the new v5 database, correct?

If so, have you properly configured the TCP/IP settings for the server? Have you opened the port(s) in the firewall?

Yes correct :slight_smile:

yes sure have opened all the ports…
even tried without firewall on…
still no go… :frowning:

I also tried the following but no working :frowning:

1.4.2. Make the Connection SambaPOS Database
After setup make SambaPOS MSSQL database connection.
– Management > Settings > Local Settings > Database
– Example Data Path : Data Source=Server; User Id=sa; Password=*******; Database=SambaPOS5;

And SQL Server protocol configuration?

SQL Server Native Client
SQL Server Network Configuration

2021-02-20_08;45_1613832349_mmc 2021-02-20_08;46_1613832365_mmc