HTML Widget URL: setting URL value with Set Widget Value Action

Is this correct? If not, please show me where I’m going wrong…

It doesn’t seem to be working for me. Plus, there is something strange going on when I set this up this way… Samba keeps going into a “busy” mode (my mouse pointer has a spinning wheel over and over again on and off).

1 Like

No worries we’ll solve it :slight_smile: Just I’m trying to understand best solution for your issue.

Do you think using printer template tags for url’s will solve this issue? If so I can implement it.

Printer Template tags for url would be great for me as well. It would solve a similar issue i have with TimeTrex.

It would make things simpler if we could pass Printer Template tags in the HTML Widget for the URL…


I was just trying to implement the Set Widget Value as you suggested, but it think I may have the syntax wrong for the Value in Set Widget Value Action. Plus, it just adds to the Rules and Actions required to pass the value, where Printer Tag support would alleviate that.

I think it should be {:CURRENTUSER} instead of [:UserName]

Or are you pulling up a stored UserName?

Yes after seeing screenshots I thought you are dealing with something that can be simply solved. Sorry for getting it a little late. I should decrease multitasking but I don’t know how to do it :slight_smile:

Instead of supporting printer template tags I’m thinking about supporting only setting reading tag. Can you think something else where we’ll need printer template tags?

Not that part @Jesse. In the Action, not the Rule…

You do not need URL:

Thats the only thing I see there.

I use a system similar to what your doing for TimeTrex let me find out how I did it and ill show you.

So how do we know which “value” we’re setting for the Widget? Because the URL is clearly not being updated…

The relation with automation command will not match atm… I am redesigning a lot I had to remake this to show what I am doing.

I was using buttons to control the login sorry If I confuse you.

It passed the value I had in the button over to the Change Widget action. It inserted Current user and i never could get it to insert a password I assume I could just store password somewhere and bring it up with a tag but I never did figure that out.

@QMcKay all widgets accepts values individually. If you set a value for html widget it uses it as URL or if you set a value for entity search widget it uses it as a search value. So you don’t need to identify value as they only accepts singe values.

I’ve implemented setting support for URL’s so you can do the same thing without using less rules and actions.

1 Like

Are you suggesting I need to use an Automation Command button Rule for this? I simply want to capture User Login Event and set the HTML Widget URL. I can’t get it to work with that event… or perhaps the Address Bar just doesn’t reflect the proper value?

No that was how I was passing it. Look at how i setup my action. I am letting value determine it. It could be that your syntax for your address bar uses a reserved char… I ran into this using # in mine… he fixed it while back to allow #. Before he fixed it… anything with # it would skip and not update url. it would just update to html:\\localhost\interface\html5\

Can we get a way to access {:TERMINAL} or [:Terminal] while we’re at it? I would expect that Login should capture this somehow. I don’t need it for my purposes since I only have 1 Terminal, but it would make things more complete.

I can’t get this to work, even without reserved characters…

I must have to do with the User Login Event not being able to change the value of the HTML Widget on the custom Entity Screen, possibly since the screen isn’t loaded. Using an Automation command embedded in the screen along with the HTML Widget must work, since they are on the same screen, and the screen is loaded and in focus with both Widgets placed on it.

@QMcKay when you switch to that custom entity screen widgets get refreshes so it reverts back to old url that configured through settings. Disabling Auto Update setting for the widget may solve your issue.

1 Like

Ah i forgot he is going to the screen technically AFTER the command to update widget is passed. This makes sense. My case it was passing it while screen was already loaded.

Tried that, still a no-go.

Thanks for confirming my suspicion though @emre, I got it to work this way…

or …


I noticed something… I was adapting my use of a button widget… it does not pass {:CURRENTUSER} into the action correctly if its entered in the widget Command button value box. The action is executing it as {:CURRENTUSER} instead of reading it and inserting the actual value.

It should have returned Admin for {:CURRENTUSER} instead it returned {:CURRENTUSER}

So it looks like Command Button Widgets cannot pass {:} syntax into the actions if the action is reading the Widget Command button Value Phew think my head hurts trying to explain this lol

Instead of passing it as a command value you can do it (read current user) inside rule that captures the button click.

1 Like