Kitchen display with timer notification?

When in Design Mode, click on the Task Editor Widget (in the middle is fine), then right-click and choose Settings. A settings dialog will appear…

Check that the Task type name value in the dialog above is set to the same as your defined Task Type (below)…

Ok, good.

If Tasks are still not showing, you need to verify the rest of the setup to ensure that it is operating properly.

Basically, something is wrong with the printing operation, so no Tasks are being printed.

I think its my printer template, can you have a look at this please for me?

This is nothing like yous but can you advise how I can mod yours to include my items please.

It is not the Template.

It is one (or a combination of) the following:

Print Job

Execute Print Job Action
Update Order State Action

Rules that handle Order State updates and Printing.

The template showing preview shows as above, so could that not be a issue?

If that is working for you, then use that Template and modify it to suit your needs. Keep in mind though - this setup is for printing Orders, not Tickets. This is why the Template has this at the top with nothing else:



My kitchen display template does not show any previous now work on the entity screen.

Can someone advise what changes I need to make to make it work.

I have already post my working template for the kitchen order printer.

Hi @QMcKay,

How do you make to show in full screen the KD?.
I can’t hide the tabs of the entity screen. I find for everywhere without results.



Which tabs? The Header? Or the blank areas to the left and right?


###Blank Areas - Task Editor Widget Properties:

Set the Width & Height to an appropriate value for the size of your monitor.


Hi QMcKay - your tutorial is pretty awesome.

I have followed it and it works although the tasks do look unusual, I have some issues with that for example, in your screenshot it makes a nice set of squares side by side but mine only show an ugly list, can you let me know where I went wrong:

Here is how mine turned out:

Review your widget settings

1 Like

I have followed the steps and functionality sounds implemented but with one issue. please check the screen for the same.

One more thing when this completed orders will disappear?

Your Task display issue is caused by your Printer Template. Show your Template here so we can figure out what is wrong with it.

Yes, they will disappear after a certain amount of time. You can adjust the time in the Task Editor Widget Settings. The setting is called Completed Task Visibility Minutes

This is the full Tutorial for this setup:

I have used exactly the same template provided above.


(Table={ENTITY NAME:Table})
(Customer={ENTITY NAME:Customer})
[='{PORTION}'=='' ? '' : '<font Consolas>  <color #FF55FF33><size 17><bold>{PORTION}</bold></size></color></font>']

<color White><bold><size 16><font Consolas>[=('{QUANTITY}'+'  ').substr(0,2)] {PRODUCT NAME}</font></size></bold></color>[='{PORTION}'=='' ? '' : '<font Consolas> <color #FF55FF33><size 14><italic>{PORTION}</italic></size></color></font>'] <bold> FREE</bold>

<color White><bold><size 16><font Consolas>[=('{QUANTITY}'+'  ').substr(0,2)] {PRODUCT NAME}</font></size></bold></color>[='{PORTION}'=='' ? '' : '<font Consolas> <color #FF55FF33><size 14><italic>{PORTION}</italic></size></color></font>'] <bold> VOID</bold>

<size 14><color Yellow><font Consolas>   [=('{ORDER TAG QUANTITY}'>1 ? {ORDER TAG QUANTITY} : ' ')] {ORDER TAG NAME}</font></color></size>

-- do not print

[SORTED ORDER TAGS:Happy Hour Discount]
-- do not print


<size 14><color LightSalmon>     ~~~ SAUTEED ~~~</color></size>

<size 14><color LightSalmon>     ~~~ ON THE SIDE ~~~</color></size>

I have set Completed task visibility Minutes to Zero. even if i am seeing the completed task.
Zero might means it stays for unlimited time i.e. until work period ends.

what should i do to immediately remove completed tasks?

You can’t AFAIK. Set it to 1 Minute.

EDIT: this might work - check the box for Don't create Task History

Also, it would be a good idea to set the Sort Order to Ascending in the Task Editor Widget Settings. That way, the oldest Order is always listed first. When marked as Complete, it will shift the Order to the bottom, out of view. After x minutes, it will disappear completely.